最长的单词

输入一个字符串,将此字符串中最长的单词输出。要求至少使用一个自定义函数。

输入格式:

测试数据有多组,处理到文件尾。每组测试数据输入一个字符串(长度不超过80)。

输出格式:

对于每组测试,输出字符串中的最长单词,若有多个长度相等的最长单词,输出最早出现的那个。这里规定,单词只能由大小写英文字母构成。

输入样例:

Keywords insert, two way insertion sort,
Abstract This paper discusses three method for two way insertion
words. insert, two way sorted.
You're a boy.

输出样例:

insertion
discusses
insert
You

代码长度限制

16 KB

时间限制

400 ms

内存限制

64 MB

#include <stdio.h>
int get_max(char s[])
{
    int i,max=0,temp=0;
    for(i=0;s[i]!='\0';i++)
    {
        if((s[i]>='A' && s[i]<='Z') || (s[i]>='a' && s[i]<='z'))
            temp++;
        else
        {
            if(temp>max)
                max=temp;
            temp=0;
            continue;
        }
    }
    return max;
}
void output_max(char s[],int max)
{
    int i,temp=0;
    for(i=0;s[i]!='\0';i++)
    {
        if((s[i]>='A' && s[i]<='Z') || (s[i]>='a' && s[i]<='z'))
            temp++;
        else
        {
            if(temp==max)
            {
                for(int j=i-temp;j<i;j++)
                    printf("%c",s[j]);
                printf("\n");
                break;
            }
            temp=0;
            continue;
        }
    }
}
int main()
{
    int max=0;
    char s[86];
    while(gets(s))
    {
        max=get_max(s);
        output_max(s,max);
    }
    return 0;
}

 

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

浮央乜

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值