Staircase | HackerRank

这篇博客介绍了一段C语言代码,用于绘制指定大小的右对齐楼梯图案,由'#'符号和空格组成。代码首先定义了一个二维字符数组,并通过两层循环填充数组。然后,通过对数组进行迭代并替换部分空格为 '#' 符号来形成楼梯形状。最后,遍历数组并打印输出。博客中提到了在不同编译器中可能存在的数组定义问题,并提供了代码示例。
摘要由CSDN通过智能技术生成

Staircase

5 more points to get your next star!
Rank: 1519966|Points: 95/100
Problem Solving
Problem
Submissions
Leaderboard
Discussions
Editorial
Staircase detail
This is a staircase of size :

Its base and height are both equal to . It is drawn using # symbols and spaces. The last line is not preceded by any spaces.
Write a program that prints a staircase of size .
Function Description
Complete the staircase function in the editor below.
staircase has the following parameter(s):
int n: an integer
Print
Print a staircase as described above.
Input Format
A single integer, , denoting the size of the staircase.
Constraints
.
Output Format
Print a staircase of size using # symbols and spaces.
Note: The last line must have spaces in it.
Sample Input
6
Sample Output
#
##

Explanation
The staircase is right-aligned, composed of # symbols and spaces, and has a height and width of .

在这里我说一下啊,在传统的编译器是不能在定义数组的时候用变量的啊,只能用常量,除非你是C++,我这是在Xcode上写的,在HackerRank上的编译器也是完全没有问题

#include<stdio.h>
int main ()
{
    int n , m ;
    scanf ("%d",&n) ;
    m = n ;
    char arr[n][m] ;//注意这里的定义,在VC++6.0上是不行的
    for ( int i = 0 ; i < n ; i ++ )//因为我不会在初始赋值的时候把一个字符赋值给所有的数组元素的方法,所以只能遍历单个输入
    {
        for ( int j = 0 ; j < m ; j ++ )
        {
            arr[i][j] = '#' ;
        }
    }
    
//    {
//        for ( int i = 0  ; i < n ; i ++ )
//        {
//            for ( int j = 0 ; j < m ; j ++ )
//            {
//                printf ("%c",arr[i][j]);
//            }
//            printf ("\n");
//        }
//    }
    
    for ( int i = 0 ; i < n ; i ++ )
    {
        for ( int j = 0 ; j < m ; j ++ )
        {
            if ( (i + j) <= (n - 2) && (i + j) >= 0 )
            {
                arr[i][j] = ' ' ;
            }
        }
    }
    for ( int i = 0 ; i < n ; i ++ )
    {
        for ( int j = 0 ; j < m ; j ++ )
        {
            printf ("%c",arr[i][j]);
        }
        printf ("\n");
    }
    printf ("\n");
    return 0;
}

在这里插入图片描述

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值