暴力法——Insertion sort (Algorithm A&D)

Sort a list in ascending order with "insertion sort" method.

Input:

Input integer n at first line, where 1<=n<=10. Then input a list of n integer numbers.

Output:

print out the list state after each pass.

Input Example:

Here is a set of inputs. For example:

6
8 4 7 5 9 6

Output Example:

The corresponding output is given here.
Note that there is a space at the end of each line.

4 8 7 5 9 6 
4 7 8 5 9 6 
4 5 7 8 9 6 
4 5 7 8 9 6 
4 5 6 7 8 9 
#include<iostream>
#include<stdio.h>
#include <cstdlib>
using namespace std;
int main()
{
    int n;
    cin >> n;
    int* a = new int[n];
    for (int i = 0; i < n; i++)
            {
                cin >> a[i];
            }
    if(n==1)
    {
        cout<<a[0]<<" "<<endl;
    }    
    else
    {
            for (int j = 1; j < n; j++)
            {
                int key = a[j];
                int i = j - 1;
                while (i >= 0 && a[i] > key)
                {
                    a[i + 1] = a[i];
                    i--;
                }
                a[i + 1] = key;
                for (int k = 0; k < n; k++)
                {
                    cout << a[k] << " ";
                }
                cout << endl;
            }
    }
    delete[] a;
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值