蜗蜗的毛衣花样c++

蜗蜗喜欢织毛衣,希望你给他设计一个毛衣的花样,要求是:给两个数a,b,输出a行b列的方阵,其中,3的倍数行为+号,3的倍数列也为+号,其他地方为.号。

输入格式

第一行,两个空格分隔的整数a,b。

输出格式

a行,每行b个符号,方阵为满足题目要求的花样。

样例输入
6 8
样例输出
..+..+..
..+..+..
++++++++
..+..+..
..+..+..
++++++++
数据范围

对于100%的数据,保证1≤a,b≤20。

方法一:

#include<bits/stdc++.h>
using namespace std;
int main(){
    int a,b;
    cin >> a >> b;
    int i,j;
    for (i = 1;i <= a;i++){
        if (i % 3 == 0)
            for (j = 1;j <= b;j++)
            cout << "+";
        else{
            for (j = 1;j <= b;j++)
                if (j % 3 == 0)
                    cout << "+";
            else
                cout << ".";
        }
        cout << endl;
    }
    return 0;            
} 

方法二:

#include<bits/stdc++.h>
using namespace std;
int main(){
    int a,b;
    cin >> a >> b;
    int i,j;
    for (i = 1;i <= a;i++){
        for (j = 1;j <= b;j++)
            if (i % 3 == 0 || j % 3 == 0)
                cout << "+";
            else
                cout << ".";
        cout << endl;
    }
    return 0;            
} 

方法三:

#include<bits/stdc++.h>
using namespace std;
int main(){
    int a,b;
    cin >> a >> b;
    int i,j;
    for (i = 1;i <= a;i++){
        for (j = 1;j <= b;j++){
            if (i % 3 != 0 && j % 3 != 0)
                cout << ".";
            else 
                cout << "+";
        }
        cout << endl;
    }
    return 0;            
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值