nyoj 364 田忌赛马

田忌赛马

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 3
描述
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.
输入
The input consists of many test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses.
输出
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

样例输入
3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
样例输出
200
0

0


可以分为三种情况考虑;

(1):田忌最慢的比赵王最慢的快 ,赢; 

(2)   : 田忌最快的比赵王最快的快, 赢;

(3):前两种都不符合的话田忌用最慢的与赵王最快的比 如果赵王的快则输,否则平局。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
using namespace std;
int main()
{
	int tj[1050],king[1050];
	int m,n,i,j;
	while(~scanf("%d",&n))
	{
		int sum=0;
		for(i=0;i<n;i++)
		scanf("%d",&tj[i]);
		for(i=0;i<n;i++)
		scanf("%d",&king[i]);
		sort(tj,tj+n);
		sort(king,king+n);
		int maxt=n-1,mint=0;//排序过后找到各自最大值最小值 
		int maxk=n-1,mink=0;
		while(mint<=maxt)//循环  
		{
			if(tj[maxt]>king[maxk])
			{
				maxt--;//与后面判断一样会更新最大最小值 
				maxk--;//记住每匹马只能用一次; 
				sum++;
			}
			else if(tj[mint]>king[mink])
			{
				mint++;
				mink++;
				sum++;
			}
			else if(tj[mint]<king[maxk])
			{
				sum--;
				mint++;
				maxk--;
			}
			else
			{
				mint++;
				maxk--;
			}	
		}
		printf("%d\n",sum*200);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值