POJ - 1426---Find The Multiple

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

    Sample Input
    2
    6
    19
    0
    Sample Output
    10
    100100100100100100
    111111111111111111

题目大意: 给出一个整数,求出能整除该数的数,但这个整数要求只能包括0和1。

思路:题目不难,简单的BFS,每次只需要依次往结尾添加0,1入队即可

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio> 
using namespace std;

//简单的BFS 
void BFS(int n){
    queue<unsigned long long> Q;

    Q.push(1);

    while(!Q.empty()){
        unsigned long long tem = Q.front();
        Q.pop();

        //找到 
        if(tem % n == 0){
            cout<<tem<<endl;
            return ;
        }else{
            //没找到给结尾添加0,1入队 
            Q.push(tem*10);
            Q.push(tem*10+1);
        }
    }

} 
int main(){
    int n;
    while(cin>>n,n){
        BFS(n);
    }
    return 0;   
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值