Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
题目大意: 给出一个整数,求出能整除该数的数,但这个整数要求只能包括0和1。
思路:题目不难,简单的BFS,每次只需要依次往结尾添加0,1入队即可
#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;
//简单的BFS
void BFS(int n){
queue<unsigned long long> Q;
Q.push(1);
while(!Q.empty()){
unsigned long long tem = Q.front();
Q.pop();
//找到
if(tem % n == 0){
cout<<tem<<endl;
return ;
}else{
//没找到给结尾添加0,1入队
Q.push(tem*10);
Q.push(tem*10+1);
}
}
}
int main(){
int n;
while(cin>>n,n){
BFS(n);
}
return 0;
}