HDU - 1495-----非常可乐

大家一定觉的运动以后喝可乐是一件很惬意的事情,但是seeyou却不这么认为。因为每次当seeyou买了可乐以后,阿牛就要求和seeyou一起分享这一瓶可乐,而且一定要喝的和seeyou一样多。但seeyou的手中只有两个杯子,它们的容量分别是N 毫升和M 毫升 可乐的体积为S (S<101)毫升 (正好装满一瓶) ,它们三个之间可以相互倒可乐 (都是没有刻度的,且 S==N+M,101>S>0,N>0,M>0) 。聪明的ACMER你们说他们能平分吗?如果能请输出倒可乐的最少的次数,如果不能输出”NO”。
Input
三个整数 : S 可乐的体积 , N 和 M是两个杯子的容量,以”0 0 0”结束。
Output
如果能平分的话请输出最少要倒的次数,否则输出”NO”。

Sample Input
7 4 3
4 1 3
0 0 0
Sample Output
NO
3

思路:此题跟倒水的那个题很相似,还是同样的过程,在代码里。

#include<iostream>
#include<cstring>
#include<queue>
#include<cstdio> 
using namespace std;
const int MAX=101;

//跟倒水的题一样,再练习一下 
struct node{
    int s,n,m; //可乐的状态 
    int step;//记录操作的步数 
}; 
int S,N,M;
bool visit[MAX][MAX][MAX];//可乐的访问状态 

int BFS(int s,int n,int m){
    queue<node> Q;

    memset(visit,false,sizeof(visit));
    node t1;

    t1.s = s;
    t1.n = 0;
    t1.m = 0;
    t1.step = 0;
    visit[t1.s][t1.n][t1.m] = true; 

    Q.push(t1);//初始情况入队 

    while(!Q.empty()){  
        node tem = Q.front();
        Q.pop();

        //找到 
        if(tem.n == S>>1 && tem.s == s>>1){
            return tem.step;
        }

        //6种操作 
        for(int i=1 ; i<=6 ; i++){
            node temp = tem;
            switch(i){
                //s->n 
                case 1:{
                    //s非空,n不满才倒 下同理 
                    if(temp.s!=0 && temp.n!=n){
                        if(temp.s+temp.n > n){
                            temp.s -= n-temp.n;
                            temp.n = n;
                        }else{
                            temp.n += temp.s;
                            temp.s = 0;
                        }
                        temp.step = tem.step+1;
                    }
                    break;
                }
                //s->m 
                case 2:{
                    if(temp.s!=0 && temp.m!=m){
                        if(temp.s+temp.m > m){
                            temp.s -= m-temp.m;
                            temp.m = m;
                        }else{
                            temp.m += temp.s;
                            temp.s = 0;
                        }
                        temp.step = tem.step+1;
                    }
                    break;
                }
                //n->s 
                case 3:{
                    if(temp.n!=0){
                        temp.s += temp.n;
                        temp.n = 0;
                        temp.step = tem.step+1;
                    }
                    break;
                }
                //n->m 
                case 4:{
                    if(temp.n!=0 && temp.m!=m){
                        if(temp.m+temp.n > m){
                            temp.n -= m-temp.m;
                            temp.m = m;
                        }else{
                            temp.m += temp.n;
                            temp.n = 0;
                        }
                        temp.step = tem.step+1;
                    }
                    break;
                }
                //m->n 
                case 5:{
                    if(temp.m!=0 && temp.n!=n){
                        if(temp.m+temp.n > n){
                            temp.m -= n-temp.n; 
                            temp.n = n;
                        }else{
                            temp.n += temp.m;
                            temp.m = 0;
                        }
                        temp.step = tem.step+1;
                    }
                    break;
                }
                //m->s 
                case 6:{
                    if(temp.m!=0){
                        temp.s += temp.m;
                        temp.m =0;
                        temp.step = tem.step+1;
                    }
                    break;      
                }
            }

            //此状态没有访问过 
            if(!visit[temp.s][temp.n][temp.m]){
                visit[temp.s][temp.n][temp.m] = true;
                Q.push(temp);
            }
        }
    }
    return 0;
} 
int main(void){
    int ans;
    while(cin>>S>>N>>M,S||N||M){
        if(S%2 == 1){
            cout<<"NO"<<endl;
            continue;
        }

        //为了方便让n>m; 
        if(N>M){
            ans=BFS(S,N,M);
        }else{
            ans=BFS(S,M,N);
        }

        if(ans == 0){
           cout<<"NO"<<endl;
        }else{
            cout<<ans<<endl;
        }
    }
    return 0;   
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值