括号匹配问题(使用栈 和 模拟栈)

Problem Description

 给你一串字符,可能包括括号、数字、字母、标点符号、空格,你的任务是检查这一串字符中的( ) ,[ ],{ }是否匹配。

Input

 输入数据有多组,处理到文件结束。

Output

 如果匹配就输出“yes”,不匹配输出“no”

Sample Input

sin(20+10)
{[}]

Sample Output

yes
no

 使用c++标准库里栈的解法:

//使用c++标准库里的栈
#include "iostream"
#include "string"
#include "stack"
using namespace std;

bool isbalance(string str)
{
	int len = str.size();
	stack<char> mystack;
	for (int i = 0; i < len; i++)
	{
		if (str[i] == '[' || str[i] == '{' || str[i] == '(')
			mystack.push(str[i]);
		else if (str[i] == ']' || str[i] == '}' || str[i] == ')')
		{
			if (mystack.empty())
			{
				cout << "no" << endl;
				return false;
			}

			if (str[i] == ']')
			{
				if ('[' != mystack.top()) return false;
				mystack.pop();

			}
			else if (str[i] == '}')
			{
				if ('{' != mystack.top()) return false;
				mystack.pop();

			}
			else if (str[i] == ')')
			{
				if ('(' != mystack.top()) return false;
				mystack.pop();

			}

		}
	}//结束for
	if (mystack.empty())
		return true;
	else
	{
		mystack.pop();
		return false;
	}

}

int main()
{
	bool bal;
	string str;
	while (cin >> str)
	{
		bal = isbalance(str);
		if (bal == true)  cout << "yes" << endl;
		else cout << "no" << endl;
	}

	return 0;
}

 不使用标准库里栈的解法:

//使用栈的思想,C语言模拟栈
#include <stdio.h>
#include <string.h>

struct stack
{
	int data[500];
	int top;
};

int main()
{
	char s[1000];
	int n , flag;//字符长度,标记量
	struct stack st;
	while (gets_s(s) != NULL)
	{
		n = strlen(s);
		flag = 1;
		st.top = -1;
		for (int i = 0; i<n; i++)
		{
			if (s[i] == '(' || s[i] == '[' || s[i] == '{')
			{
				st.top++;
				st.data[st.top] = s[i]; 
				
			}
			else if (s[i] == ')')
			{
				if (st.top != -1 && st.data[st.top] == '(')
				{
					st.top--;//注意实际没有删除栈顶的元素
			
				}
				else
				{
					printf("no\n");
					flag = 0;
					break;
				}
			}
			else if (s[i] == ']')
			{
				if (st.top != -1 && st.data[st.top] == '[')
				{
					st.top--;
				}
				else
				{
					printf("no\n");
					flag = 0;
					break;
				}
			}
			else if (s[i] == '}')
			{
				if (st.top != -1 && st.data[st.top] == '{')
				{
					st.top--;
				}
				else
				{
					printf("no\n");
					flag = 0;
					break;
				}
			}
		}
		if (flag == 1)
		{
			if (st.top == -1)
			{
				printf("yes\n");
			}
			else
			{
				printf("no\n");
			}
		}
	}
	return 0;
}


 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值