HDU 3236 Gift Hunting 题解(动态规划)

点击打开链接

Gift Hunting

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1109    Accepted Submission(s): 369


Problem Description
After winning two coupons for the largest shopping mart in your city, you can't wait inviting your girlfriend for gift hunting. Having inspected hundreds of kinds of souvenirs, toys and cosmetics, you finally narrowed down the candidate list to only n gifts, numbered 1 to n. Each gift has a happiness value that measures how happy your girlfriend would be, if you get this gift for her. Some of them are special - you must get it for your girlfriend (note that whether a gift is special has nothing to do with its happiness value).

Coupon 1 can be used to buy gifts with total price not greater than V1 (RMB). Like most other coupons, you can’t get any money back if the total price is strictly smaller than V1. Coupon 2 is almost the same, except that it’s worth V2. Coupons should be used separately. That means you cannot combine them into a super-coupon that’s worth V1+ V2. You have to divide the gifts you choose into two part, one uses coupon 1, the other uses coupon 2.

It is your girlfriend's birthday today. According to the rules of the mart, she can take one (only one) gift for FREE! Here comes your challenge: how to make your girlfriend as happy as possible?
 

Input
There will be at most 20 test cases. Each case begins with 3 integers V1, V2 and n (1 <= V1 <= 500, 1 <= V2 <= 50, 1 <= n <= 300), the values of coupon 1 and coupon 2 respectively, and the number of candidate gifts. Each of the following n lines describes a gift with 3 integers: P, H and S, where P is the price, H is the happiness (1 <= P,H <= 1000), S=1 if and only if this is a special gift - you must buy it (or get it for free). Otherwise S=0. The last test case is followed by V1 = V2 = n = 0, which should not be processed.
 

Output
For each test case, print the case number and the maximal total happiness of your girlfriend. If you can't finish the task, i.e. you are not able to buy all special gifts even with the 1-FREE bonus, the happiness is -1 (negative happiness means she's unhappy). Print a blank line after the output of each test case.
 

Sample Input
  
  
3 2 4 3 10 1 2 10 0 5 100 0 5 80 0 3 2 4 3 10 1 2 10 0 5 100 0 5 80 1 0 0 0
 

Sample Output
  
  
Case 1: 120 Case 2: 100
题意:买家 有两张价值分别为v1、v2的优惠劵,n个物品,每个物品有三个属性:价格,快乐值,是否必须买,买家还可以免费拿一个物品,一张优惠劵只能使用一次,换句话说如果优惠劵上的钱没用完,也不能再用了。所以总金钱不是v1+v2。问能得到的最大的快乐值?如果不能把所有必须买的都买了,则输出-1。

这个题可以用dp来做,每个物品最多只有买或不买,如果买用第一种优惠劵买或是用第二种优惠劵买或是免费拿这几种策略,状态还是比较容易想出来的,dp[i][j][k][0,1]表示前i物品已经选了,第一张优惠劵使用j元钱,第二张优惠劵使用了k元钱,一次免费的权利是否使用的状态下能得到的最大快乐值。状态转移则按照物品的属性以及策略进行转移就行了,具体见代码:(当然需要用滚动数组优化空间)

#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<vector>
#include<algorithm>
#include<queue>
#include<stack>
#include<math.h>
#define nn 110
#define inff 0x3fffffff
#define mod 1000000007
#define eps 1e-9
using namespace std;
typedef long long LL;
int v1,v2,n;
int p[310],h[310],s[310];
int dp[2][510][55][2];//滚动数组优化空间
int main()
{
    int i,j,k;
    int cas=1;
    while(scanf("%d%d%d",&v1,&v2,&n)&&v1+v2+n)
    {
        for(i=1;i<=n;i++)
        {
            scanf("%d%d%d",&p[i],&h[i],&s[i]);
        }
        for(i=0;i<=1;i++)//初始化
        {
            for(j=0;j<=v1;j++)
            {
                for(k=0;k<=v2;k++)
                {
                    dp[i][j][k][0]=dp[i][j][k][1]=-inff;
                }
            }
        }
        dp[0][0][0][0]=0;
        int t=1;
        for(i=1;i<=n;i++)
        {
            for(j=0;j<=v1;j++)
            {
                for(k=0;k<=v2;k++)
                {
                    if(s[i]==0)//不买这个商品
                    {
                        dp[t][j][k][0]=dp[1-t][j][k][0];
                        dp[t][j][k][1]=dp[1-t][j][k][1];
                    }
                    if(j-p[i]>=0)//用第一种优惠劵买
                    {
                        dp[t][j][k][0]=max(dp[t][j][k][0],dp[1-t][j-p[i]][k][0]+h[i]);
                        dp[t][j][k][1]=max(dp[t][j][k][1],dp[1-t][j-p[i]][k][1]+h[i]);
                    }
                    if(k-p[i]>=0)//用第二种优惠劵买
                    {
                        dp[t][j][k][0]=max(dp[t][j][k][0],dp[1-t][j][k-p[i]][0]+h[i]);
                        dp[t][j][k][1]=max(dp[t][j][k][1],dp[1-t][j][k-p[i]][1]+h[i]);
                    }
                    dp[t][j][k][1]=max(dp[t][j][k][1],dp[1-t][j][k][0]+h[i]);//免费获得这个商品
                }
            }
            t=1-t;
            for(j=0;j<=v1;j++)
            {
                for(k=0;k<=v2;k++)
                    dp[t][j][k][0]=dp[t][j][k][1]=-inff;
            }
        }
        int ans=-inff;
        for(i=0;i<=v1;i++)
        {
            for(j=0;j<=v2;j++)
            {
                ans=max(ans,dp[1-t][i][j][0]);
                ans=max(ans,dp[1-t][i][j][1]);
            }
        }
        printf("Case %d: %d\n",cas++,max(-1,ans));
        puts("");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值