poj 3468 A Simple Problem with Integers

15 篇文章 0 订阅
6 篇文章 0 订阅

Description

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.


Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.

The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.

Each of the next Q lines represents an operation.

"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.

"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.


Output

You need to answer all Q commands in order. One answer in a line.


Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4


Sample Output

4
55
9
15


Hint

The sums may exceed the range of 32-bit integers.


用long long!!!

题解

用线段树做区间修改与区间求和


代码

#include<cstdio>
#include<algorithm>
#define N 100010
#define lson l,mid,rt<<1
#define rson mid+1,r,rt<<1|1
using namespace std;
typedef long long ll;
ll f[N<<2];
ll add[N<<2];
int n,q;
char s[N];

void PushUp(int rt)
{
	f[rt]=f[rt<<1]+f[rt<<1|1];
}

void PushDown(int rt,int m)
{
	if(add[rt])
	{
		add[rt<<1]+=add[rt];
		add[rt<<1|1]+=add[rt];
		f[rt<<1]+=add[rt]*(m-(m>>1));
		f[rt<<1|1]+=add[rt]*(m>>1);
		add[rt]=0;
	}
}

void build(int l,int r,int rt)
{
	add[rt]=0;
	if(l==r)
	{
		scanf("%lld",&f[rt]);
		return ;
	}
	int mid=(r+l)>>1;
	build(lson);
	build(rson);
	PushUp(rt);
}

ll query(int L,int R,int l,int r,int rt)
{
	if(l>=L&&r<=R)
		return f[rt];
	PushDown(rt,r-l+1);
	int mid=(r+l)>>1;
	ll ret=0;
	if(mid>=L)
		ret+=query(L,R,lson);
	if(mid<R)
		ret+=query(L,R,rson);
	return ret;
}

void update(int L,int R,int c,int l,int r,int rt)
{
	if(l>=L&&r<=R)
	{
		add[rt]+=c;
		f[rt]+=(ll)c*(r-l+1);
		return ;
	}
	PushDown(rt,r-l+1);
	int mid=(l+r)>>1;
	if(mid>=L)
		update(L,R,c,lson);
	if(mid<R)
		update(L,R,c,rson);
	PushUp(rt);
}

int main()
{
	scanf("%d%d",&n,&q);
	build(1,n,1);
	while(q--)
	{
		int x,y,z;
		scanf("%s",s);
		if(s[0]=='Q')
		{
			scanf("%d%d",&x,&y);
			printf("%lld\n",query(x,y,1,n,1));
		}else
		{
			scanf("%d%d%d",&x,&y,&z);
			update(x,y,z,1,n,1);
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值