HDU 4432 求因子+进制转换

Sum of divisors
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5053    Accepted Submission(s): 1674


Problem Description
mmm is learning division, she's so proud of herself that she can figure out the sum of all the divisors of numbers no larger than 100 within one day!
But her teacher said "What if I ask you to give not only the sum but the square-sums of all the divisors of numbers within hexadecimal number 100?" mmm get stuck and she's asking for your help.
Attention, because mmm has misunderstood teacher's words, you have to solve a problem that is a little bit different.
Here's the problem, given n, you are to calculate the square sums of the digits of all the divisors of n, under the base m.
 

Input
Multiple test cases, each test cases is one line with two integers.
n and m.(n, m would be given in 10-based)
1≤n≤109
2≤m≤16
There are less then 10 test cases.
 

Output
Output the answer base m.
 

Sample Input

10 2
30 5

 

Sample Output

110
112
Hint

Use A, B, C...... for 10, 11, 12......
Test case 1: divisors are 1, 2, 5, 10 which means 1, 10, 101, 1010 under base 2, the square sum of digits is

1^2+ (1^2 + 0^2) + (1^2 + 0^2 + 1^2) + .... = 6 = 110 under base 2.


2012天津区域赛第二水题:

题意:每行输入一个十进制数,再输入一个进制。

先找出每个数的因数,化为输入的进制,把累加每个数位的平方和,得到一个十进制数,再转换进制。

纯模拟题,集合了求因子和进制转换的模拟手法,就是在16进制上的处理要小心点,直接让模拟杀手老胡做了,老胡博客传送门  http://home.cnblogs.com/u/pach/

下面直接搬他的代码并做注释:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;

typedef long long ll; //自定义长整形,方便下面的敲
int n,m;
ll sum;
char s[1000];
int ar[1000];
void Transform1(int x)
{
    memset(ar,0,sizeof(ar));
    for(int i=0;x>0;i++)  //因子转换进制后每个数位累加和
    {
        ar[i]=x%m;
        x=x/m;
        sum+=(ar[i])*(ar[i]);
    }
}
void Transform2()
{
    memset(s,0,sizeof(s));
    for(int i=0;sum>0;i++)
    {
        if(sum%m<10) //进制转换老套方法,先取模,再除
            s[i]=sum%m+'0';
        else
            s[i]=sum%m-10+'A';
        sum=sum/m;
    }
}
void Find_divisor()
{
    sum=0;
    for(int i=1;i<=pow(n,1.0/2);i++)
    {
        if(n%i==0)
        {
            Transform1(i);
            if(i!=n/i)  //去掉25的因子为5重复找两次的情况
            Transform1(n/i);//每次可以找两个因子,继续转换后面的因子,如10的因子1和10,2和5,而2肯定小于sqort(10);
        }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdin);
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        sum=0;
        Find_divisor();
        Transform2();//高出10进制的有字母表示,但本质还是代表了那个数位的大小,所以在因子转换数位的累加和上不需要进制字符转换,只需要在最后的表示上转换字符即可
        for(int i=strlen(s)-1;i>=0;i--)
            putchar(s[i]);
        printf("\n");
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值