【问题描述】
从键盘接收用户输入的字符串, 对用户输入的每个字符串的处理是:将字符串内的每一个十进制数字字符置换成下列表格中右边所对应的一个字符串(所有其他字符不变),然后将转换的结果显示在屏幕上;并分别计算每个数字的置换次数。
十进制数字字符
置换成
0
(Zero)
1
(One)
2
(Two)
3
(Three)
4
(Four)
5
(Five)
6
(Six)
7
(Seven)
8
(Eight)
9
(Nine)
例如,若用户输入的字符串为
Page112-Line3,
则程序5的输出是:
Page(One) (One) (Two)-Line(Three),
数字0到9的置换次数分别是 0 2 1 1 0 0 0 0 0 0
【输入形式】
输入一行字符串,其中可包含字母、数字、空格或其他符号(英文)
【输出形式】
第一行为将字符串中的数字转换为表格中的内容后输出
第二行为数字0~9被转换的次数
【样例输入】
Page112-Line3
【样例输出】
Page(One)(One)(Two)-Line(Three)
0 2 1 1 0 0 0 0 0 0
#include<iostream>
#include<string>
using namespace std;
int main(){
string str;
getline(cin,str);
int len=str.length();
int a[10];
for(int i=0;i<10;i++)
a[i]=0;
for(int i=0;i<len;i++){
if(str[i]=='0'){
cout<<"(Zero)";
a[0]++;
}
else if(str[i]=='1'){
cout<<"(One)";
a[1]++;
}
else if(str[i]=='2'){
cout<<"(Two)";
a[2]++;
}
else if(str[i]=='3'){
cout<<"(Three)";
a[3]++;
}
else if(str[i]=='4'){
cout<<"(Four)";
a[4]++;
}
else if(str[i]=='5'){
cout<<"(Five)";
a[5]++;
}
else if(str[i]=='6'){
cout<<"(Six)";
a[6]++;
}
else if(str[i]=='7'){
cout<<"(Seven)";
a[7]++;
}
else if(str[i]=='8'){
cout<<"(Eight)";
a[8]++;
}
else if(str[i]=='9'){
cout<<"(Nine)";
a[9]++;
}
else
cout<<str[i];
}
cout<<endl;
for(int i=0;i<10;i++)
cout<<a[i]<<" ";
return 0;
}