湖南大学21夏训练四18.身份证校验

【问题描述】

我国国标〖GB 11643-1999〗中规定:公民身份号码是18位特征组合码,由十七位数字本体码和一位数字校验码组成。排列顺序从左至右依次为:六位数字地址码,八位数字出生日期码,三位数字顺序码和一位数字校验码。其校验码(最后一位)计算方法和步骤为:

(1)十七位数字本体码加权求和公式

S = Sum(Ai * Wi), i = 0, … , 16 ,先对前17位数字的权求和

其中Ai:表示第i位置上的身份证号码数字值

Wi:表示第i位置上的加权因子,前17位加权因子从左到右分别为

Wi:7 9 10 5 8 4 2 1 6 3 7 9 10 5 8 4 2

(2)计算模

Y = mod(S, 11)

(3)通过模Y查下表得到对应的校验码

Y

0

1

2

3

4

5

6

7

8

9

10

校验码

1

0

X

9

8

7

6

5

4

3

2

例如:某身份证前17位为11010519491231002

i

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

wi

7

9

10

5

8

4

2

1

6

3

7

9

10

5

8

4

2

1

1

0

1

0

5

1

9

4

9

1

2

3

1

0

0

2

7

9

0

5

0

20

2

9

24

27

7

18

30

5

0

0

4

得到和为:167;则模为y=167%11=2

查(3)得校验码为X(大写)

请按上面所述步骤编程,输入一个二代身份证号,检查该身份证是否正确。

【输入形式】

输入若干行,每行一个身份证号码,最后一行输入-1

【输出形式】

输出1代表正确,0代表错误

【样例输入】

120223198902021249
130132199210293822
130402198207290622
-1
【样例输出】

1
1
0

#include<iostream>
#include<string>
#include<sstream>
using namespace std;
int main(){
	string str;
	stringstream ss;
	int a[18];
	while(cin>>str){
		if(str=="-1")
		break;
		for(int i=0;i<17;i++){//str的最后一位别输进去! 
			ss.clear();
			ss<<str[i];
			ss>>a[i];
		}
		int sum=0;
		sum=a[0]*7+a[1]*9+a[2]*10+a[3]*5+a[4]*8+a[6]*2
		+a[7]+a[8]*6+a[5]*4+a[9]*3+a[10]*7+a[11]*9+a[12]*10
		+a[13]*5+a[14]*8+a[15]*4+a[16]*2;
		int res=sum%11;
		char ch;
		if(res==0)
		ch='1';
		else if(res==1)
		ch='0';
		else if(res==2)
		ch='X';
		else if(res==3)
		ch='9';
		else if(res==4)
		ch='8';
		else if(res==5)
		ch='7';
		else if(res==6)
		ch='6';
		else if(res==7)
		ch='5';
		else if(res==8)
		ch='4';
		else if(res==9)
		ch='3';
		else if(res==10)
		ch='2';
		if(ch==str[17])
		cout<<"1"<<endl;
	    else  
		cout<<"0"<<endl;
			}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值