字符逆序(charAt的使用)

字符逆序

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
将一个字符串str的内容颠倒过来,并输出。str的长度不超过100个字符。
Input
输入包括一行。
第一行输入的字符串。
Output
输出转换好的逆序字符串。
Sample Input
I am a student
Sample Output
tneduts a ma I
Hint

字符串的最后一个字符是n-1 而不是n 即第一个字符是0

import java.util.Scanner;
public class Main {
	public static void main(String[] args) {
		  Scanner input = new Scanner(System.in);
		  String str;
		  char s;
		  str = input.nextLine();
		  int i, j, n;
		  n = str.length();
		  for(i = n-1; i>= 0; i--) {
			 s = str.charAt(i);
			 System.out.print(s);
		  }
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值