DedeCMS错误:(PHP 5.3和以上)请将“request_order”ini值设置为PHP .ini中包含的C、G和P(推荐:“CGP”)。

原创 2018年04月16日 15:46:02

背景

项目转移到另一台服务器后出现以下错误:


DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP') in php.ini,more...

DedeCMS错误:(PHP 5.3和以上)请将“request_order”ini值设置为PHP .ini中包含的C、G和P(推荐:“CGP”)。


解决方法

然后上网查找解决方法:“这一般出现在新主机,老版本的dedecms上,看提示就知道,需要改服务器的php.ini配置文件,但是一般大家用的都是虚拟主机,没有权限修改,所以我们还是改dedecms文件吧,把这个报错执行代码注释掉,找到包括/ common.inc.php文件吧


参考:https://blog.csdn.net/ebalzhang/article/details/47441927

Please set 'request_order' ini value to include C,G and P (recommended: 'CGP') in php.ini

今天刚刚安装dede,安装完成由一条错误信息(PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P ...
  • u010433704
  • u010433704
  • 2016-03-09 16:10:34
  • 1572

php.ini中的request_order设置

今天刚刚安装dede,安装完成由一条错误信息(PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P...
  • u012948710
  • u012948710
  • 2014-03-18 08:52:35
  • 1837

DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value to i报错解决方法

这一般出现在新主机,老版本的dedecms上,看提示就知道,需要改服务器的php.ini配置文件,但是一般大家用的都是虚拟主机,没有权限修改,所以我们还是改dedecms文件吧,把这个报错执行代码注释...
  • ebalZhang
  • ebalZhang
  • 2015-08-12 11:32:10
  • 10853

(PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP') i

修改一下 include/common.inc.php 文件就行了,将 32行至36行注释掉或者删除就可以了, /* if(version_compare(PHP_VERSION, '5.3.0'...
  • bixing
  • bixing
  • 2014-02-18 01:09:26
  • 1471

织梦报错提示 DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P

织梦报错提示 DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P...
  • qq_29362889
  • qq_29362889
  • 2016-12-22 19:05:58
  • 1067

(PHP 5.3 and above) Please set ‘request_order’ ini value to include C,G and P (recommended: ‘CGP’) i

由于在PHP最新的版本中增加了一个配置项目“request_order”,默认值为“GP”,这个存在一定的安全风险。这里我们建议用户将配置更改为“CGP” 方法一: 可以在phpinfo中查看...
  • cctv1937
  • cctv1937
  • 2015-07-06 09:48:06
  • 245

兔子-(PHP 5.3 and above) Please set 'request_order' ini value to include C,G and P (recommended: 'CGP'

由于在PHP最新的版本中增加了一个配置项目“request_order”,默认值为“GP”,这个存在一定的安全风险。这里我们建议用户将配置更改为“CGP” 可以在php的安装目录下找到php.i...
  • u013425527
  • u013425527
  • 2015-11-29 11:12:50
  • 398

php配置文件php.ini详解(php版本5.3.0)

short_open_tag = Off
  • kexiaoling
  • kexiaoling
  • 2014-07-31 16:26:36
  • 1330

使用php函数ini_set()重新设置某个配置的设置值

使用PHP的ini_set()函数 ini_set (PHP 4, PHP 5, PHP 7) ini_set — 为一个配置选项设置值 说明 string ini_...
  • caoyouming0609
  • caoyouming0609
  • 2018-01-19 11:30:14
  • 266

PHP扩展:如何使用ini变量

在扩展中,有时候需要使用在php.ini中设定的值,在PHP的扩展中 使用ini变量的方式如下:首先使用:   PHP_INI_BEGIN()   PHP_INI_ENTRY("foo_bar.glo...
  • barfoo
  • barfoo
  • 2007-04-03 18:12:00
  • 3843
收藏助手
不良信息举报
您举报文章:DedeCMS错误:(PHP 5.3和以上)请将“request_order”ini值设置为PHP .ini中包含的C、G和P(推荐:“CGP”)。
举报原因:
原因补充:

(最多只允许输入30个字)