poj2251

题目名称:Dungeon Master

题目链接:http://poj.org/problem?id=2251


Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!


题意:给一个3d版的有L层,每层有R行,C列的地牢,求从S到E所用的最少时间

思路:用dfs求最短路

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<string>
#include<queue>
using namespace std;
const int INF=0x3f3f3f;
struct Node
{
    int i,j,k,sum;
};
queue<Node> q;
char a[31][31][31];
bool vis[31][31][31];
int a1,a2,b1,b2,c1,c2,res;
int L,R,C,ok=0;
int dir[6][3]={-1,0,0,1,0,0,0,-1,0,0,1,0,0,0,-1,0,0,1};
void bfs()
{
    Node s;
	s.i=a1,s.j=b1,s.k=c1,s.sum=0;
    while(!q.empty()) q.pop();
    vis[a1][b1][c1]=true;
    q.push(s);
    while(!q.empty())   //bfs能确保到达时时间最少
    {
        Node now=q.front();
        q.pop();
        Node tmp;
        for(int p=0;p<6;p++)
        {
			int i=now.i+dir[p][0];
			int j=now.j+dir[p][1];
			int k=now.k+dir[p][2];
			if(i>=L||i<0||j>=R||j<0||k>=C||k<0) continue;
			if(vis[i][j][k]) continue;
			if(a[i][j][k]=='#') continue;
			vis[i][j][k]=true;
			tmp.i=i;
			tmp.j=j;
			tmp.k=k;
			tmp.sum=now.sum+1;
			q.push(tmp);
            if(i==a2&&j==b2&&k==c2)
            {
                ok=1;
                res=tmp.sum;
                return;
            }
        }
    }
}
int main()
{
    while(scanf("%d%d%d%*c",&L,&R,&C)!=EOF)
    {
        if(L==0&&R==0&&C==0)
            break;
        for(int i=0;i<L;i++)
        {
            for(int j=0;j<R;j++)
            {
                for(int k=0;k<C;k++)
                {
                    scanf("%c",&a[i][j][k]);
                    if(a[i][j][k]=='S')
                    {
                        a1=i;
                        b1=j;
                        c1=k;
                    }
                    if(a[i][j][k]=='E')
                    {
                        a2=i;
                        b2=j;
                        c2=k;
                    }
                }
                getchar();
            }
            getchar();
        }
        ok=0;
        memset(vis,false,sizeof(vis));
        bfs();
        if(ok==0)
            printf("Trapped!\n");
        else
            printf("Escaped in %d minute(s).\n",res);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值