1053. Path of Equal Weight

Path of Equal Weight

Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

image

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 2 30 2^{30} 230, the given weight number. The next line contains N positive numbers where Wi (< 1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, …, An} is said to be greater than sequence {B1, B2, …, Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, … k, and A k + 1 &gt; B k + 1 A_{k+1} &gt; B_{k+1} Ak+1>Bk+1.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

题意

给定一棵树及所有结点的权值,求出所有从根节点到叶子结点的路径,使得每条路径上权值之和等于给定常数s,依次输出路径上的权值。若路径不唯一,则按非递增顺序(类似字典序,以权值为关键字)输出所有路径。

思路

DFS,遍历所有可能的路径,计算权值之和。处理过程中注意剪枝,当权值之和已经大于s时则无需再递归下去;另一点要注意的是题目要求非递增输出,则可在读入数据的时候,对每一个结点的孩子结点按照其权值从大到小进行排序,这样就可以保证遍历时总是先遍历权值大的路线。


代码实现

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

const int maxn = 100;
vector<int> path;       // 记录路径

struct Node
{
    int w;
    vector<int> child;
} node[maxn];

bool cmp(int a, int b)
{
    return node[a].w > node[b].w;
}

void findPath(int root, int sum, int s)
{
    if (sum > s)        // 剪枝,权值和已经超过s则结束
        return;

    if (sum == s)
    {
        if (!node[root].child.empty())      // 注意判断此时是否是叶子结点,若不是则该路线不满足要求,结束
            return;

        for (int i = 0; i < path.size(); i++)       //  是叶子结点且权值和等于s,则输出
        {
            if (i > 0)
                printf(" ");
            printf("%d", node[path[i]].w);
        }
        printf("\n");
        return;
    }

    for (int i = 0; i < node[root].child.size(); i++)
    {
        int child = node[root].child[i];
        path.push_back(child);      // 路径保存下一个结点
        findPath(child, sum + node[child].w, s);
        path.pop_back();    // 处理完毕则在路径中去除该结点
    }
}

int main()
{
    int n, m, s;
    int id, k, x;

    scanf("%d%d%d", &n, &m, &s);
    for (int i = 0; i < n; i++)
        scanf("%d", &node[i].w);
    for (int i = 0; i < m; i++)
    {
        scanf("%d%d", &id, &k);
        for (int j = 0; j < k; j++)
        {
            scanf("%d", &x);
            node[id].child.push_back(x);
        }
        sort(node[id].child.begin(), node[id].child.end(), cmp);    // 对各结点的子节点按照其权值从大到小排列
    }

    path.push_back(0);
    findPath(0, node[0].w, s);

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值