1086. Tree Traversals Again

Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

image

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题意

给定结点数,并列出创建二叉树时的入栈出栈顺序,要求输出该二叉树的后序遍历序列。

**思路 **

模拟一下样例的入栈出栈,不难发现入栈顺序对应于二叉树的先序遍历,出栈顺序对应于二叉树的中序遍历,这样问题就转化为已知先序序列和中序序列,要求重建二叉树并输出后序序列。具体操作可移步 《先序中序后序求二叉树》


代码实现

#include <cstdio>
#include <stack>
#include <vector>
using namespace std;

vector<int> pre, in;    // 存放先序序列和中序序列
stack<int> s;           // 栈操作
bool flag = true;       // flag用来控制空格输出

struct node
{
    int data;
    node* lchild;
    node* rchild;
};

void solve(char op[])       // 处理入栈出栈操作
{
    int x;
    if (op[1] == 'u')       // 只要判断第二个字符,入栈
    {
        scanf("%d", &x);
        s.push(x);
        pre.push_back(x);   // 入栈对应先序
    }
    else                    // 出栈
    {
        x = s.top();
        s.pop();
        in.push_back(x);    // 出栈对应中序
    }
}

node* create(int preL, int preR, int inL, int inR)      // 由先序序列和中序序列重建二叉树
{
    if (preL > preR)
        return NULL;

    node* root = new node;
    root->data = pre[preL];

    int k;
    for (k = inL; k <= inR; k++)
        if (in[k] == pre[preL])
            break;
    int numLeft = k - inL;

    root->lchild = create(preL + 1, preL + numLeft, inL, k - 1);
    root->rchild = create(preL + numLeft + 1, preR, k + 1, inR);

    return root;
}

void postOrder(node* root)      // 后序遍历
{
    if (root == NULL)
        return;

    postOrder(root->lchild);
    postOrder(root->rchild);
    if (flag)
        flag = false;
    else
        printf(" ");
    printf("%d", root->data);
}

int main()
{
    int n;
    char op[5];

    scanf("%d", &n);
    for (int i = 0; i < 2 * n; i++)
    {
        scanf("%s", op);
        solve(op);
    }

    node* root = create(0, n - 1, 0, n - 1);    // 重建二叉树
    postOrder(root);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值