1142. Maximal Clique

Maximal Clique

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (<= 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (<= 100). Then M lines of query follow, each first gives a positive number K (<= Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line “Yes” if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print “Not Maximal”; or if it is not a clique at all, print “Not a Clique”.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

题意

团为图g中的一个子图h,且该子图中任意两个顶点之间都有一条边,若将图g中任一剩余结点加入到h中都无法使h扩大为更大的一个团,就说h是极大团。

现给定图中所有结点和边,要求判断给定的子图是否是一个团,以及是否是一个极大团。

思路

因为结点数上限仅为200,直接按照定义穷举遍历即可通过。


代码实现

#include <cstdio>
#include <vector>
#include <cstring>
using namespace std;

const int maxn = 201;
int nv, ne;
bool g[maxn][maxn] = {false};       // 邻接矩阵
vector<int> cl;                     // 记录子图结点
bool hashTable[maxn] = {false};     // 判断是否为子图结点

bool isClique()     // 判断是否为团
{
    // 直接遍历,判断子图两两结点之间是否有边
    for (int i = 0; i < cl.size() - 1; i++)
        for (int j = i + 1; j < cl.size(); j++)
            if (g[cl[i]][cl[j]] == false)       // 如果无边,说明不是团
                return false;
    return true;
}

bool isMaximal()    // 判断是否为极大团
{
    for (int i = 1; i <= nv; i++)       // 遍历图中所有非子图结点
    {
        if (hashTable[i] == false)
        {
            bool flag = true; 
            for (int j = 0; j < cl.size(); j++)     // 判断该结点是否与所有子图结点有边
                if (g[i][cl[j]] == false)           // 若无边,说明添加该结点无法扩大团
                    flag = false;
            if (flag == true)       // 若与所有子图结点都有边,说明不是极大团
                return false;
        }
    }
    return true;
}

int main()
{
    int a, b;
    int m, k, x;

	scanf("%d%d", &nv, &ne);
    for (int i = 0; i < ne; i++)
    {
        scanf("%d%d", &a, &b);
        g[a][b] = g[b][a] = true;
    }

    for (int i = 1; i <= nv; i++)       // 注意结点与自身之间要定义为有边
        g[i][i] = true;

    scanf("%d", &m);
    for (int i = 0; i < m; i++)
    {
        // 初始化操作
        memset(hashTable, false, sizeof(hashTable));
        cl.clear();

        scanf("%d", &k);
        for (int j = 0; j < k; j++)
        {
            scanf("%d", &x);
            cl.push_back(x);
            hashTable[x] = true;        // 标记子图结点
        }

        if (isClique() == false)
            printf("Not a Clique\n");
        else if (isMaximal() == false)
            printf("Not Maximal\n");
        else
            printf("Yes\n");
    }

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值