几何题,二分法 fz1148

        几何问题,求出寻找宽度的公式。。

         二分法暴力寻找

A narrow street is lined with tall buildings. An x foot long ladder is rested at the base of the building on the right side of the street and leans on the building on the left side. A y foot long ladder is rested at the base of the building on the left side of the street and leans on the building on the right side. The point where the two ladders cross is exactly c feet from the ground. How wide is the street?


 Input

Each line of input contains three positive floating point numbers giving the values of  xy, and  c.

 Output

For each line of input, output one line with a floating point number giving the width of the street in feet, with three decimal digits in the fraction.

 Sample Input

30 40 1012.619429 8.163332 310 10 310 10 1

 Sample Output

26.0337.0008.0009.798
#include<stdio.h>
#include<math.h>
#define Min(a,b) a<=b?a:b
double x,y,c;
double ans(double w)
{
    return 1-c/sqrt(y*y-w*w)-c/sqrt(x*x-w*w);
}
int main()
{

    while(scanf("%lf %lf %lf",&x,&y,&c)!=EOF)
    {
        double l=0,sum,r=Min(x,y);

        while(r-l>10e-8)
        {
            sum=(l+r)/2;
            if(ans(sum)>0)
            {
                l=sum;
            }
            else
                r=sum;

        }
        //printf("###\n");
        printf("%.3lf\n",sum);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值