poj 1328 Radar Installation 区间找点问题

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
 
     
 
     
PS:贪心思想:以每个岛屿为中心,给定的半径为半径画圆,有三种情况出现,与水平线有一个交点,有两个节点,没有交点(这种情况输出数出负一即可)前两种情况可以归为一类,既有交点。最后在水平线上会有许多区域,有的区域重合,这时在重合的地方放一个雷达可以同时覆盖多个区域。
    可以以每组的左交点为基准由小到大排序,这样以第一个的左端点对应的右端点为起始右端点,当下一个重叠区域的右交点小于右端点,更新右端点为现在的右交点,当下一个的左交点大于当前的右端点是雷达树量加一重复以前几步即可。注意本题雷达被放的位置可能不为整数,所以可以定义有关的变量为double型即可。
 
     
 
     
代码:
#include<stdio.h>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<string.h>
using namespace std;
struct SS
{
    double left;
    double right;
} s[1020],k;
bool cmp(SS A,SS B)
{
    if(A.left==B.left)
        return A.right>B.right;
    return A.left<B.left;
}
int main()
{
    int m,t=0,sum;
    double a,b,n;
    while(~scanf("%d %lf",&m,&n))
    {
        int f=0;
        if(m==0&&n==0)
            break;
        t++;

        for(int i=0; i<m; i++)
        {
            scanf("%lf %lf",&a,&b);
            if(abs(b)>n)
                f=1;
            else
            {
                s[i].left=a*1.0-sqrt(n*n-b*b);
                s[i].right=a*1.0+sqrt(n*n-b*b);
            }

        }
        if(f==0)
        {
             sum=1;
            sort(s,s+m,cmp);
            k=s[0];

            for(int i=1; i<m; i++)
            {
                if(k.right<s[i].left)
                {
                    sum++;
                    k=s[i];
                }
                else if(k.right>s[i].right)
                {
                    k=s[i];
                }
            }
        }
        if(f==1)
            printf("Case %d: -1\n",t);
        else
            printf("Case %d: %d\n",t,sum);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值