uva 133(模拟)

154 篇文章 0 订阅
82 篇文章 0 订阅

 In a serious attempt to downsize (reduce) the dole queue, The NewNational Green Labour Rhinoceros Party has decided on the followingstrategy. Every day all dole applicants will be placed in a largecircle, facing inwards. Someone is arbitrarily chosen as number 1,and the rest are numbered counter-clockwise up to N (who will bestanding on 1's left). Starting from 1 and moving counter-clockwise,one labour official counts off k applicants, while another officialstarts from N and moves clockwise, counting m applicants. The two whoare chosen are then sent off for retraining; if both officials pickthe same person she (he) is sent off to become a politician. Eachofficial then starts counting again at the next available person andthe process continues until no-one is left. Note that the two victims(sorry, trainees) leave the ring simultaneously, so it is possible forone official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) thethree numbers (N, k and m; k, m > 0, 0 < N < 20) and determinethe order in which the applicants are sent off for retraining. Eachset of three numbers will be on a separate line and the end of datawill be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the orderin which people are chosen. Each number should be in a field of 3characters. For pairs of numbers list the person chosen by thecounter-clockwise official first. Separate successive pairs (orsingletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4tex2html_wrap_inline34 8,tex2html_wrap_inline34 9tex2html_wrap_inline34 5,tex2html_wrap_inline34 3tex2html_wrap_inline34 1,tex2html_wrap_inline34 2tex2html_wrap_inline34 6,tex2html_wrap_inline50 10,tex2html_wrap_inline34 7

where tex2html_wrap_inline50represents a space. 


题目意思是输入3个数n,a,b,表示有n个人顺时针围成一圈,第一个人起顺时针隔a个去掉一个,第n个人起逆时针隔b个去掉一个,输出每次去掉的人的原始编号;

模拟题。自行想办法模拟,也可参考我代码:(这题最坑的是输出的空格,不是输出空格而是占3个位置)


#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
     int n,a,b;
     while(cin>>n>>a>>b&&!(a==0&&b==0))
     {
        int x[n+1];
        for(int i=1;i<=n;i++)
            x[i]=i;
        int l=0,r=n+1;
        while(1)
        {
            int flag=0,s=0;
            for(int i=1;i<=n;i++)
                if(x[i]!=0)
            {
                s++;
                flag=1;
            }//cout<<s<<endl;
            if(flag==0)
                break;
            int a0=a,b0=b;
            while(a0>0)
            {
                if(l==n)
                    l=1;
                else l++;
            if(x[l]!=0)
                a0--;
               // cout<<l<<' '<<x[l]<<endl;
            }
            while(b0>0)
            {

               // cout<<r<<endl;
                if(r==1)
                    r=n;
                else r--;
                 if(x[r]!=0)
                b0--;
            }
            if(r==l&&s!=1)
            {
                printf("%3d",x[r]);
                cout<<',';
            }
            else if(r==l&&s==1)
            {
                printf("%3d",x[r]);
                cout<<endl;;
            }
        else if(r!=l&&s!=2)
            {
                printf("%3d%3d",x[l],x[r]);
                cout<<',';
            }
            else if(r!=l&&s==2)
            {
                printf("%3d%3d",x[l],x[r]);
                 cout<<endl;
            }
            x[r]=0;x[l]=0;
        }
     }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值