hdu1116(欧拉回路)

123 篇文章 0 订阅
82 篇文章 0 订阅

Description

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us. 

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word ``acm'' can be followed by the word ``motorola''. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door. 

Input

The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters 'a' through 'z' will appear in the word. The same word may appear several times in the list.

Output

Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times. 
If there exists such an ordering of plates, your program should print the sentence "Ordering is possible.". Otherwise, output the sentence "The door cannot be opened.". 

Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.


题意:判断n个单词是否可以相连成一条链或一个环,两个单词可以相连的条件是 前一个单词的最后一个字母和后一个单词的第一个字母一样。

分析:有向图的欧拉回路判断

链: 头 入度==出度-1 ;中间 入度==出度 ; 尾 入度==出度+1;
 
注:
欧拉回路的定义:图G的一个回路,若它恰通过G中每条边一次,则称该回路为欧拉(Euler)回路

欧拉回路判断:判断基于此图的基图连通。

1、图存在欧拉回路的充要条件:一个无向图存在欧拉回路,当且仅当该图所有顶点度数都是偶数且该图是连通图。

2、图存在欧拉回路的充要条件:一个有向图存在欧拉回路,所有顶点的入度等于出度且该图是连通图。


这题得用并查集来找头,不过许多人说这题用并查集的方法来写我觉得就不太准确了。


(在此提出一个疑问,我用的查找入度为0且存在的字母为头来写为啥死活不a????(当然输入时如果首尾两个字符相同,我就不加入度和出度,这样就不会重复,各种测试数据都过了)求大牛看到助解答)

下面是没a的我觉得很正确的代码呜呜呜~~~~~~~

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[27][27],rd[30],cd[30],cz[26];
char cc[1010];
int n;
bool hh()
{
    int s=0,k;
    for(int i=0;i<26;i++)
    if(rd[i]==0&&cz[i]==1)s++,k=i;
    if(s!=1&&s!=0)
        return 0;
    else
    {
        int x=0,y=0,z=0;
        for(int i=0;i<26;i++)
        if(rd[i]==cd[i])
        x++;
        else if(rd[i]-cd[i]==1)
        y++;
        else if(rd[i]-cd[i]==-1)
        z++;
        else
        return 0;
        if((y==0&&z==0)||(y==1&&z==1))
        return 1;
        else return 0;
    }
}

int main()
{
   int t;
   scanf("%d",&t);
   while(t--)
   {
       memset(a,0,sizeof(a));
       memset(rd,0,sizeof(rd));
       memset(cd,0,sizeof(cd));
       memset(cz,0,sizeof(cz));
        scanf("%d",&n);
        while(n--)
       {
           //getchar();
           scanf("%s",cc);
       int l=strlen(cc);
    if(cc[0]-'a'!=cc[l-1]-'a')
    {
        if(a[cc[0]-'a'][cc[l-1]-'a']==0)
       a[cc[0]-'a'][cc[l-1]-'a']++;
        rd[cc[l-1]-'a']++;
        cd[cc[0]-'a']++;
    }
        if(cz[cc[0]-'a']==0)
       cz[cc[0]-'a']=1;
        if(cz[cc[l-1]-'a']==0)
       cz[cc[l-1]-'a']=1;
       }
       int h=hh();
       if(h)printf("Ordering is possible.\n");
       else printf("The door cannot be opened.\n");
   }
    return 0;
}


下面附上我改成并查集的方法后的代码:(真是气死人!!一改成并查集就a了!!!)

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int f[100010],rd[30],cd[30],cz[26];
char cc[1010];
int n;

int ff(int x)
{
    if(x==f[x])return x;
    return ff(f[x]);
}

void hh()
{
    int s=0,k;
    for(int i=0;i<26;i++)
    if(f[i]==i&&cz[i]==1)s++,k=i;
   // cout<<s<<endl;
    if(s>1)
        {
            printf("The door cannot be opened.\n");
            return ;
        }
    else
    {
        int z=0,y=0;
        for(int i=0;i<26;i++)
        if(cz[i]==1&&rd[i]!=cd[i])
        {
        if(rd[i]-cd[i]==1)
        y++;
        else if(rd[i]-cd[i]==-1)
        z++;
        else
        {
            printf("The door cannot be opened.\n");
            return ;
        }
        }
        if((y==0&&z==0)||(y==1&&z==1))
        {
            printf("Ordering is possible.\n");
            return ;
        }
        else
        {
            printf("The door cannot be opened.\n");
            return;
        }
    }
}


int main()
{
   int t;
   scanf("%d",&t);
   while(t--)
   {
       memset(rd,0,sizeof(rd));
       memset(cd,0,sizeof(cd));
       memset(cz,0,sizeof(cz));
       for(int i=0;i<100000;i++)
       f[i]=i;
        scanf("%d",&n);
        while(n--)
       {
        scanf("%s",cc);
       int l=strlen(cc);
        rd[cc[l-1]-'a']++;
        cd[cc[0]-'a']++;
        f[cc[l-1]-'a']=f[cc[0]-'a']=ff(cc[0]-'a');
        if(cz[cc[0]-'a']==0)
       cz[cc[0]-'a']=1;
        if(cz[cc[l-1]-'a']==0)
       cz[cc[l-1]-'a']=1;
       }
        hh();
   }
    return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值