hdu3081(欧拉回路)

202 篇文章 0 订阅
123 篇文章 0 订阅

Ant Trip

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2261    Accepted Submission(s): 878


Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country. 

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
 

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.
 

Output
For each test case ,output the least groups that needs to form to achieve their goal.
 

Sample Input
  
  
3 3 1 2 2 3 1 3 4 2 1 2 3 4
 

Sample Output
  
  
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.

给出一个图,需要几笔能画完题目所描述的所有边。

给出的图是无向图。。。刚开始还以为是二分图的最小路径覆盖。。。无语了。。

用并查集把子图都分开,然后判断每个是否是欧拉回路,如果是那就一笔就ok,如果不是那就需要这个子图里面的奇度数/2笔,然后算出来就好。。


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
const int N=100010;
int rd[N],f[N],js[N];
bool vis[N];
vector<int>c;
int fa(int x)
{
    if(x!=f[x])
        return f[x]=fa(f[x]);
    return f[x];
}
int main()
{
    int m,n;
    while(~scanf("%d%d",&n,&m))
    {
        c.clear();
        for(int i=1; i<=n; i++)
            f[i]=i;
        memset(rd,0,sizeof(rd));
        while(m--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            rd[a]++;
            rd[b]++;
            if(fa(a)!=fa(b))
                f[fa(a)]=fa(b);
        }
        memset(vis,0,sizeof(vis));
        memset(js,0,sizeof(js));
        for(int i=1; i<=n; i++)
        {
            int x=fa(i);
            if(!vis[x]&&rd[x])
            {
                vis[x]=1;
                c.push_back(x);
            }
            if(rd[i]&1)
                js[x]++;
        }
        int l=c.size(),ans=0;
        for(int i=0; i<l; i++)
            if(js[c[i]]==0)
                ans++;
            else
                ans+=js[c[i]]/2;
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值