hdu5025(bfs,状态压缩)

202 篇文章 0 订阅
154 篇文章 0 订阅

Saving Tang Monk

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1913    Accepted Submission(s): 682


Problem Description
《Journey to the West》(also 《Monkey》) is one of the Four Great Classical Novels of Chinese literature. It was written by Wu Cheng'en during the Ming Dynasty. In this novel, Monkey King Sun Wukong, pig Zhu Bajie and Sha Wujing, escorted Tang Monk to India to get sacred Buddhism texts. 

During the journey, Tang Monk was often captured by demons. Most of demons wanted to eat Tang Monk to achieve immortality, but some female demons just wanted to marry him because he was handsome. So, fighting demons and saving Monk Tang is the major job for Sun Wukong to do.

Once, Tang Monk was captured by the demon White Bones. White Bones lived in a palace and she cuffed Tang Monk in a room. Sun Wukong managed to get into the palace. But to rescue Tang Monk, Sun Wukong might need to get some keys and kill some snakes in his way.

The palace can be described as a matrix of characters. Each character stands for a room. In the matrix, 'K' represents the original position of Sun Wukong, 'T' represents the location of Tang Monk and 'S' stands for a room with a snake in it. Please note that there are only one 'K' and one 'T', and at most five snakes in the palace. And, '.' means a clear room as well '#' means a deadly room which Sun Wukong couldn't get in.

There may be some keys of different kinds scattered in the rooms, but there is at most one key in one room. There are at most 9 kinds of keys. A room with a key in it is represented by a digit(from '1' to '9'). For example, '1' means a room with a first kind key, '2' means a room with a second kind key, '3' means a room with a third kind key... etc. To save Tang Monk, Sun Wukong must get ALL kinds of keys(in other words, at least one key for each kind).

For each step, Sun Wukong could move to the adjacent rooms(except deadly rooms) in 4 directions(north, west, south and east), and each step took him one minute. If he entered a room in which a living snake stayed, he must kill the snake. Killing a snake also took one minute. If Sun Wukong entered a room where there is a key of kind N, Sun would get that key if and only if he had already got keys of kind 1,kind 2 ... and kind N-1. In other words, Sun Wukong must get a key of kind N before he could get a key of kind N+1 (N>=1). If Sun Wukong got all keys he needed and entered the room in which Tang Monk was cuffed, the rescue mission is completed. If Sun Wukong didn't get enough keys, he still could pass through Tang Monk's room. Since Sun Wukong was a impatient monkey, he wanted to save Tang Monk as quickly as possible. Please figure out the minimum time Sun Wukong needed to rescue Tang Monk.
 

Input
There are several test cases.

For each case, the first line includes two integers N and M(0 < N <= 100, 0<=M<=9), meaning that the palace is a N×N matrix and Sun Wukong needed M kinds of keys(kind 1, kind 2, ... kind M). 

Then the N × N matrix follows.

The input ends with N = 0 and M = 0.
 

Output
For each test case, print the minimum time (in minutes) Sun Wukong needed to save Tang Monk. If it's impossible for Sun Wukong to complete the mission, print "impossible"(no quotes).
 

Sample Input
  
  
3 1 K.S ##1 1#T 3 1 K#T .S# 1#. 3 2 K#T .S. 21. 0 0
 

Sample Output
  
  
5 impossible 8

题意:'T'表示师傅,'K'表示孙悟空,'#'是不能进去的区域,'.'是可以走的区域,数字表示第i把钥匙,一定要按照1,2,3,4……的顺序拿钥匙,'S'表示蛇,如果有蛇就要先杀死蛇,花费时间是1,每走一步花费时间1,求悟空找到师傅的最短时间。

思路:用f[x][y][k][s]表示在坐标为(x,y)的位置已经拿到k把钥匙,杀死了蛇的状态为s的状态,通过建立这样一个数组来使bfs能不重复计算。


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
typedef long long ll;
const int INF=99999999;
char a[105][105];
int fx[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};
bool f[105][105][10][(1<<5)+1];
int n,m,bj,xx,yy;
struct data
{
    int x,y,k,s,d;
    data(int x0,int y0,int k0,int s0,int d0)
    {
        x=x0,y=y0,k=k0,s=s0,d=d0;
    }
};
int bfs()
{
    int ans=INF;
    queue<data>q;
    data hh(xx,yy,0,0,0);
    q.push(hh);
    while(!q.empty())
    {
        data t=q.front();
        q.pop();
        int x=t.x,y=t.y;
        if(a[x][y]=='T'&&t.k==m)
            ans=min(ans,t.d);
        if(!f[x][y][t.k][t.s])
        {
            f[x][y][t.k][t.s]=1;
            for(int i=0; i<4; i++)
            {
                int tx=x+fx[i][0],ty=y+fx[i][1];
                if(tx<0||tx>=n||ty<0||ty>=n||a[tx][ty]=='#')
                    continue;
                int tt=a[tx][ty]-'A';
                if(tt>=0&&tt<bj)
                {
                    if((1<<tt)&t.s)
                    {
                        data neww(tx,ty,t.k,t.s,t.d+1);
                        q.push(neww);
                    }
                    else
                    {
                        data neww(tx,ty,t.k,t.s|(1<<tt),t.d+2);
                        q.push(neww);
                    }
                }
                else
                {
                    if(a[tx][ty]=='1'+t.k)
                    {
                        data neww(tx,ty,t.k+1,t.s,t.d+1);
                        q.push(neww);
                    }
                    else
                    {
                        data neww(tx,ty,t.k,t.s,t.d+1);
                        q.push(neww);
                    }
                }
            }
        }
    }
    return ans;
}

int main()
{
    while(~scanf("%d%d",&n,&m)&&n+m)
    {
        bj=0;
        memset(a,0,sizeof(a));
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                scanf(" %c",&a[i][j]);
                if(a[i][j]=='K')
                    xx=i,yy=j;
                else if(a[i][j]=='S')
                    a[i][j]='A'+bj,bj++;
            }
        memset(f,0,sizeof(f));
        int ss=bfs();
        if(ss==INF)
            printf("impossible\n");
        else printf("%d\n",ss);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值