poj1087(最大流)

202 篇文章 0 订阅
123 篇文章 0 订阅

A Plug for UNIX
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15470 Accepted: 5248

Description

You are in charge of setting up the press room for the inaugural meeting of the United Nations Internet eXecutive (UNIX), which has an international mandate to make the free flow of information and ideas on the Internet as cumbersome and bureaucratic as possible. 
Since the room was designed to accommodate reporters and journalists from around the world, it is equipped with electrical receptacles to suit the different shapes of plugs and voltages used by appliances in all of the countries that existed when the room was built. Unfortunately, the room was built many years ago when reporters used very few electric and electronic devices and is equipped with only one receptacle of each type. These days, like everyone else, reporters require many such devices to do their jobs: laptops, cell phones, tape recorders, pagers, coffee pots, microwave ovens, blow dryers, curling 
irons, tooth brushes, etc. Naturally, many of these devices can operate on batteries, but since the meeting is likely to be long and tedious, you want to be able to plug in as many as you can. 
Before the meeting begins, you gather up all the devices that the reporters would like to use, and attempt to set them up. You notice that some of the devices use plugs for which there is no receptacle. You wonder if these devices are from countries that didn't exist when the room was built. For some receptacles, there are several devices that use the corresponding plug. For other receptacles, there are no devices that use the corresponding plug. 
In order to try to solve the problem you visit a nearby parts supply store. The store sells adapters that allow one type of plug to be used in a different type of outlet. Moreover, adapters are allowed to be plugged into other adapters. The store does not have adapters for all possible combinations of plugs and receptacles, but there is essentially an unlimited supply of the ones they do have.

Input

The input will consist of one case. The first line contains a single positive integer n (1 <= n <= 100) indicating the number of receptacles in the room. The next n lines list the receptacle types found in the room. Each receptacle type consists of a string of at most 24 alphanumeric characters. The next line contains a single positive integer m (1 <= m <= 100) indicating the number of devices you would like to plug in. Each of the next m lines lists the name of a device followed by the type of plug it uses (which is identical to the type of receptacle it requires). A device name is a string of at most 24 alphanumeric 
characters. No two devices will have exactly the same name. The plug type is separated from the device name by a space. The next line contains a single positive integer k (1 <= k <= 100) indicating the number of different varieties of adapters that are available. Each of the next k lines describes a variety of adapter, giving the type of receptacle provided by the adapter, followed by a space, followed by the type of plug.

Output

A line containing a single non-negative integer indicating the smallest number of devices that cannot be plugged in.

Sample Input

4 
A 
B 
C 
D 
5 
laptop B 
phone C 
pager B 
clock B 
comb X 
3 
B X 
X A 
X D 

Sample Output

1

题意:

1、在一个会议室里有n种插座,每种插座一个;

2、每个插座只能插一种以及一个电器(或者适配器);

3、有m个电器,每个电器有一个插头需要插在相应一种插座上;

4、不是所有电器都能在会议室找到相应插座;

5、有k种适配器,每种适配器可以有无限多数量;

6、每种适配器(a, b)可以把b类插座变为a类插座;

7、问最后有多少个电器无法使用。

分析:

我们可以理解为把将电器插到插座上通电使用这个过程视为网络流的过程,所以从源点出发,连接电器,电器连接插座,插座之间由适配器有相互关系,然后将插座连汇点。

由于适配器有无限多种,所以插座之间由适配器连边的时候权值设为无穷大,其他的都只有一个,所以边权设为1。

总结;

这题写完哇了10次,都是由于自己的大意与粗心造成的,说到底还是自己菜,建边的过程确实自己搞的有点麻烦了。。。


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<iomanip>
using namespace std;
typedef long long ll;
const   int oo=1e9;
/**oo 表示无穷大*/
const  int mm=200000;
/**mm 表示边的最大数量,记住要是原图的两倍,在加边的时候都是双向的*/
const  int mn=999;
/**mn 表示点的最大数量*/
int node,src,dest,edge;
/**node 表示节点数,src 表示源点,dest 表示汇点,edge 统计边数*/
int ver[mm],flow[mm],nex[mm];
int head[mn],work[mn],dis[mn],q[mn];
void prepare(int _node, int _src,int _dest)
{
    node=_node,src=_src,dest=_dest;
    for(int i=0; i<=node; ++i)head[i]=-1;
    edge=0;
}
void addedge( int u,  int v,  int c)
{
    ver[edge]=v,flow[edge]=c,nex[edge]=head[u],head[u]=edge++;
    ver[edge]=u,flow[edge]=0,nex[edge]=head[v],head[v]=edge++;
}
bool Dinic_bfs()
{
    int i,u,v,l,r=0;
    for(i=0; i<node; ++i)dis[i]=-1;
    dis[q[r++]=src]=0;
    for(l=0; l<r; ++l)
        for(i=head[u=q[l]]; i>=0; i=nex[i])
            if(flow[i]&&dis[v=ver[i]]<0)
            {
                dis[q[r++]=v]=dis[u]+1;
                if(v==dest)  return 1;
            }
    return 0;
}
int Dinic_dfs(  int u, int exp)
{
    if(u==dest)  return exp;
    for(int &i=work[u],v,tmp; i>=0; i=nex[i])
        if(flow[i]&&dis[v=ver[i]]==dis[u]+1&&(tmp=Dinic_dfs(v,min(exp,flow[i])))>0)
        {
            flow[i]-=tmp;
            flow[i^1]+=tmp;
            return tmp;
        }
    return 0;
}
int Dinic_flow()
{
    int i,ret=0,delta;
    while(Dinic_bfs())
    {
        for(i=0; i<node; ++i)work[i]=head[i];
        while((delta=Dinic_dfs(src,oo)))ret+=delta;
    }
    return ret;
}
char s1[210][50],s2[210][50],s3[210][50];
int nnn[210][2];
int main()
{
    int n,m;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
            scanf("%s",s1[i]);
        scanf("%d",&m);
        int num=0;
        for(int i=1; i<=m; i++)
        {
            scanf("%s%s",s2[i],s3[i]);
            int flag=0;
            for(int j=1; j<=n; j++)
                if(strcmp(s1[j],s3[i])==0)
                {
                    flag=1;
                    break;
                }
            if(!flag)
            {
                num++;
                n++;
                strcpy(s1[n],s3[i]);
            }
        }
        int k;
        scanf("%d",&k);
        for(int h=0; h<k; h++)
        {
            char t1[30],t2[30];
            int u=-1,v=-1;
            scanf("%s%s",t1,t2);
            for(int i=1; i<=n; i++)
                if(strcmp(t1,s1[i])==0)
                {
                    u=i;
                    break;
                }
            for(int i=1; i<=n; i++)
                if(strcmp(t2,s1[i])==0)
                {
                    v=i;
                    break;
                }
            if(u==-1)
            {
                strcpy(s1[++n],t1);
                num++;
                u=n;
            }
            if(v==-1)
            {
                strcpy(s1[++n],t2);
                num++;
                v=n;
            }
            nnn[h][0]=u+m,nnn[h][1]=v+m;
        }
        prepare(n+m+2,0,n+m+1);
        int st=0,ed=n+m+1;
        for(int i=1; i<=n-num; i++)
            addedge(i+m,ed,1);
        for(int i=1; i<=m; i++)
        {
            addedge(st,i,1);
            for(int j=1; j<=n; j++)
                if(strcmp(s1[j],s3[i])==0)
                    addedge(i,j+m,1);
        }
        for(int i=0; i<k; i++)
            addedge(nnn[i][0],nnn[i][1],oo);
        printf("%d\n",m-Dinic_flow());
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值