Walk
Time Limit: 30000/15000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 957 Accepted Submission(s): 610
Special Judge
Problem Description
I used to think I could be anything, but now I know that I couldn't do anything. So I started traveling.
The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.
If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
The nation looks like a connected bidirectional graph, and I am randomly walking on it. It means when I am at node i, I will travel to an adjacent node with the same probability in the next step. I will pick up the start node randomly (each node in the graph has the same probability.), and travel for d steps, noting that I may go through some nodes multiple times.
If I miss some sights at a node, it will make me unhappy. So I wonder for each node, what is the probability that my path doesn't contain it.
Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.
T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
For each test case, the first line contains 3 integers n, m and d, denoting the number of vertices, the number of edges and the number of steps respectively. Then m lines follows, each containing two integers a and b, denoting there is an edge between node a and node b.
T<=20, n<=50, n-1<=m<=n*(n-1)/2, 1<=d<=10000. There is no self-loops or multiple edges in the graph, and the graph is connected. The nodes are indexed from 1.
Output
For each test cases, output n lines, the i-th line containing the desired probability for the i-th node.
Your answer will be accepted if its absolute error doesn't exceed 1e-5.
Your answer will be accepted if its absolute error doesn't exceed 1e-5.
Sample Input
2 5 10 100 1 2 2 3 3 4 4 5 1 5 2 4 3 5 2 5 1 4 1 3 10 10 10 1 2 2 3 3 4 4 5 5 6 6 7 7 8 8 9 9 10 4 9
Sample Output
0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.0000000000 0.6993317967 0.5864284952 0.4440860821 0.2275896991 0.4294074591 0.4851048742 0.4896018842 0.4525044250 0.3406567483 0.6421630037
概率dp,用dp[i][j]表示走过i步之后到达j点的概率是多少。
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<iomanip>
using namespace std;
typedef long long ll;
double dp[10010][55];
vector <int>tu[55];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m,d;
scanf("%d%d%d",&n,&m,&d);
for(int i=0; i<=n; i++)
tu[i].clear();
while(m--)
{
int a,b;
scanf("%d%d",&a,&b);
tu[a].push_back(b);
tu[b].push_back(a);
}
memset(dp,0,sizeof(dp));
for(int a=1; a<=n; a++)
{
memset(dp,0,sizeof(dp));
for(int i=1; i<=n; i++)
dp[0][i]=1.0/(double)n;
for(int i=0; i<d; i++)
for(int j=1; j<=n; j++)
if(j!=a)
{
int l=tu[j].size();
for(int k=0; k<l; k++)
{
int to=tu[j][k];
dp[i+1][to]+=dp[i][j]*1.0/(double)l;
}
}
double s=0;
for(int i=1; i<=n; i++)
if(i!=a)
s+=dp[d][i];
printf("%.10f\n",s);
}
}
return 0;
}