hdu3652(数位dp)

202 篇文章 0 订阅
78 篇文章 0 订阅

B-number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4184    Accepted Submission(s): 2397


Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 

Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 

Output
Print each answer in a single line.
 

Sample Input
  
  
13 100 200 1000
 

Sample Output
  
  
1 1 2 2

题意:求从1到n含有13且能整除13的数有多少个。

思路:数位dp,找状态转移方程和边界条件就好。dp[i][j][k]含义看代码。

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
int dp[22][13][3];
/*
   dp[i][j][0]:前i位对13取余为j的不含13的个数。
  dp[i][j][1]:前i位对13取余为j的不含13且i+1位是1的个数。
  dp[i][j][2]:前i位对13取余为j的含13的个数。
*/
int digit[22];
int dfs(int pos,int mod,int st,bool limit)
{
    if(pos==0)  return st==2&&mod==0;
    if(!limit&&dp[pos][mod][st]!=-1)return dp[pos][mod][st];
    int ans=0;
    int end=limit?digit[pos]:9;
    for(int i=0; i<=end; i++)
        if((st==1&&i==3)||st==2)
            ans+=dfs(pos-1,(mod*10+i)%13,2,limit&&(i==end));
        else if(i==1)
            ans+=dfs(pos-1,(mod*10+i)%13,1,limit&&(i==end));
        else ans+=dfs(pos-1,(mod*10+i)%13,0,limit&&(i==end));
    if(!limit)
        dp[pos][mod][st]=ans;
    return ans;
}
int get(int x)
{
    int bj=0;
    while(x)
        digit[++bj]=x%10,x/=10;
    return dfs(bj,0,0,1);
}
int main()
{
    memset(dp,-1,sizeof(dp));
    int n;
    while(~scanf("%d",&n))
        printf("%d\n",get(n));
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值