hdu1045(二分图)

202 篇文章 0 订阅
123 篇文章 0 订阅

Fire Net

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9579    Accepted Submission(s): 5579


Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
  
  
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
  
  
5 1 5 2 4

题意:‘X'是墙,现在要在空地上尽可能多的放置机关枪,可是在一片连续的空地上每行每列只能有一个机关枪,墙很厚,被墙隔着的可以视作不在同一行或同一列,要求最多的放置机关枪的数目。

思路:这题主要在于怎样去建图,和hdu5039这题建图方式一样,详细请看:http://blog.csdn.net/martinue/article/details/51286032


#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;
const int N=555;///两边的最大数量
bool tu[N][N];
int from[N];///记录右边的点如果配对好了它来自哪里
bool use[N];///记录右边的点是否已经完成了配对
int n,m;///m,n分别表示两边的各自数量,n是左边,m是右边
bool dfs(int x)
{
    for(int i=1; i<=m; i++) ///m是右边,所以这里上界是m
        if(!use[i]&&tu[x][i])
        {
            use[i]=1;
            if(from[i]==-1||dfs(from[i]))
            {
                from[i]=x;
                return 1;
            }
        }
    return 0;
}
int hungary()
{
    int tot=0;
    memset(from,-1,sizeof(from));
    for(int i=1; i<=n; i++) ///n是左边,所以这里上界是n
    {
        memset(use,0,sizeof(use));
        if(dfs(i))
            tot++;
    }
    return tot;
}
char a[10][10];
int p1[10][10];
int main()
{
    int x;
    while(~scanf("%d",&x)&&x)
    {
        memset(tu,0,sizeof(tu));
        memset(p1,0,sizeof(p1));
        for(int i=0; i<x; i++)
            scanf("%s",a[i]);
        int bj1=0,bj2=0,flag=0;
        for(int i=0; i<x; i++)
        {
            flag=0;
            for(int j=0; j<x; j++)
                if(!flag&&a[i][j]!='X')
                    p1[i][j]=++bj1,flag=1;
                else if(flag&&a[i][j]=='X')
                    flag=0;
                else if(flag&&a[i][j]!='X')
                    p1[i][j]=bj1;
        }
        for(int j=0; j<x; j++)
        {
            flag=0;
            for(int i=0; i<x; i++)
                if(!flag&&a[i][j]!='X')
                    bj2++,tu[p1[i][j]][bj2]=tu[bj2][p1[i][j]]=1,flag=1;
                else if(flag&&a[i][j]=='X')
                    flag=0;
                else if(flag&&a[i][j]!='X')
                    tu[p1[i][j]][bj2]=tu[bj2][p1[i][j]]=1;
        }
        m=bj1,n=bj2;
        printf("%d\n",hungary());
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值