poj2955(简单区间dp)

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im n, ai1ai2aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

题意:给出一串括号字符,求最多的匹配个数。

思路:找到转移方程就好。

max0=max(max0,dp[i][k]+dp[k+1][j]);

if((s[i]=='('&&s[j]==')')||(s[i]=='['&&s[j]==']'))

dp[i][j]=max(max0,dp[i+1][j-1]+1);

else

dp[i][j]=max0;

#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#include<stack>
using namespace std;
typedef long long ll;

int dp[110][110];
char s[110];
int fdp(int a,int b)
{
    if(a>=b)return 0;
    if(dp[a][b]!=-1)return dp[a][b];
    int max0=0;
    for(int i=a; i<b; i++)
        max0=max(max0,fdp(a,i)+fdp(i+1,b));
    if((s[a]=='('&&s[b]==')')||(s[a]=='['&&s[b]==']'))
        return dp[a][b]=max(max0,fdp(a+1,b-1)+1);
    else
        return dp[a][b]=max0;
}

int main()
{
    while(~scanf("%s",s))
    {
        if(strcmp(s,"end")==0)
            break;
        int l=strlen(s);
        memset(dp,-1,sizeof(dp));
        printf("%d\n",fdp(0,l-1)<<1);
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值