hdu5773(2016多校第四场,最长上升子序列n*logn变形)

202 篇文章 0 订阅
154 篇文章 0 订阅

The All-purpose Zero

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1097    Accepted Submission(s): 271


Problem Description
?? gets an sequence S with n intergers(0 < n <= 100000,0<= S[i] <= 1000000).?? has a magic so that he can change 0 to any interger(He does not need to change all 0 to the same interger).?? wants you to help him to find out the length of the longest increasing (strictly) subsequence he can get.
 

Input
The first line contains an interger T,denoting the number of the test cases.(T <= 10)
For each case,the first line contains an interger n,which is the length of the array s.
The next line contains n intergers separated by a single space, denote each number in S.
 

Output
For each test case, output one line containing “Case #x: y”(without quotes), where x is the test case number(starting from 1) and y is the length of the longest increasing subsequence he can get.
 

Sample Input
  
  
2 7 2 0 2 1 2 0 5 6 1 2 3 3 0 0
 

Sample Output
  
  
Case #1: 5 Case #2: 5
Hint
In the first case,you can change the second 0 to 3.So the longest increasing subsequence is 0 1 2 3 5.
题意:0可以任意更改,求最长上升子序列。

思路:n*logn方法的代码里面改改就好了。

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;

#define M 100005
#define INF 1000005
using namespace std;
int data[M];
int dp[M];
int g[M];
void init(int n)
{
    for(int i=1; i<=n; i++)
        g[i]=INF;
    g[0]=-INF;
    for(int i=0; i<n; i++)
        dp[i]=0;
}
int LIS(int n)
{
    init(n);
    int maxn=1;
    int cnt=0;
    for(int i=0; i<n; i++)
    {
        if(data[i]==0)
        {
            if(i==0)
            {
                g[1]=-INF+1;
                continue;
            }
            cnt++;
            /*for(int j=1; j<=maxn; j++)
                cout<<g[j]<<" ";
            cout<<endl;*/
            continue;
        }
        int k=lower_bound(g+1,g+n+1,data[i]-cnt)-g;//最长不递减子序列则改为upper_bound
        dp[i]=k;
        g[k]=data[i]-cnt;
        if(dp[i]>=maxn) maxn=dp[i];

        /*for(int j=1; j<=maxn; j++)
            cout<<g[j]<<" ";
        cout<<endl;*/

    }
    return maxn+cnt;
}

int main()
{
    int n,T,c=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%d",&data[i]);
        int ans=LIS(n);
        printf("Case #%d: %d\n",c++,ans);
    }

    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值