hdu5875(思维题)

154 篇文章 0 订阅
46 篇文章 0 订阅

Function

Time Limit: 7000/3500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 472    Accepted Submission(s): 178


Problem Description
The shorter, the simpler. With this problem, you should be convinced of this truth.
  
  You are given an array A of N postive integers, and M queries in the form (l,r) . A function F(l,r) (1lrN) is defined as:
F(l,r)={AlF(l,r1) modArl=r;l<r.
You job is to calculate F(l,r) , for each query (l,r) .
 

Input
There are multiple test cases.
  
  The first line of input contains a integer T , indicating number of test cases, and T test cases follow.
  
  For each test case, the first line contains an integer N(1N100000) .
  The second line contains N space-separated positive integers: A1,,AN (0Ai109) .
  The third line contains an integer M denoting the number of queries.
  The following M lines each contain two integers l,r (1lrN) , representing a query.
 

Output
For each query (l,r) , output F(l,r) on one line.
 

Sample Input
  
  
1 3 2 3 3 1 1 3
 

Sample Output
  
  
2

题意:求一个区间里面第一个数一次对后面的所有数取余的结果。

思路:这题数据比较水,要敢写,取余比自己大的数就是自己本身,所以预处理一个指向的数组,指向后面的第一个比自己小的数,然后求结果会优化很多。

#pragma comment(linker, "/STACK:102400000,102400000")
#include <iostream>
#include<string.h>
#include<vector>
#include<queue>
#include<algorithm>
#include<stdio.h>
#include<math.h>
#include<map>
#include<stdlib.h>
#include<time.h>
#include<stack>
#include<set>
using namespace std;
typedef long long ll;
int a[100010],nex[100010];
int main()
{
    int t;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            int n;
            scanf("%d",&n);
            for(int i=1; i<=n; i++)
                scanf("%d",&a[i]);
            for(int i=1; i<=n; i++)
            {
                nex[i]=-1;
                for(int j=i+1; j<=n; j++)
                    if(a[j]<=a[i])
                    {
                        nex[i]=j;
                        break;
                    }
            }
            int q;
            scanf("%d",&q);
            while(q--)
            {
                int l,r;
                scanf("%d%d",&l,&r);
                int ans=a[l];
                for(int i=nex[l]; i<=r; i=nex[i])
                {
                    if(i==-1)break;
                    ans%=a[i];
                }
                printf("%d\n",ans);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值