hdu1394 线段树求逆序数

Minimum Inversion Number

Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output
For each case, output the minimum inversion number on a single line.

Sample Input
10
1 3 6 9 0 8 5 7 4 2

Sample Output
16

这题对原序列求一次逆序数即可。
根据数学推导:
i次将第一个元素移动到末尾后序列的逆序数 = 第i-1次将第一个元素移动到末尾后序列的逆序数 + n - 1 - 2 * X [ i ]
然后循环n-1次取最小值就可以啦~

#include<iostream>
#include<stdio.h>
#define maxn 5007  //元素总个数
using namespace std;
int x[maxn];
int M[maxn << 2];//存区间最小值
int n;
void PushUp(int rt) { M[rt] = min(M[rt << 1] , M[rt << 1 | 1]); }

void Build(int l, int r, int rt) {
    if (l == r) {
        M[rt] = x[l];
        return;
    }
    int m = (l + r) >> 1;
    Build(l, m, rt << 1);
    Build(m + 1, r, rt << 1 | 1);
    PushUp(rt);
}

int Query(int L, int R, int l, int r, int rt,int val) {
    if (l==r) {
        if(M[rt]>val)
            return 0;
        else
            return 1;
    }
    if(l>=L&&r<=R&&M[rt]>val)
        return 0;
    int m = (l + r) >> 1;
    int ANS = 0;
    if (L <= m) ANS +=Query(L, R, l, m, rt << 1,val);
    if (R >  m) ANS +=Query(L, R, m + 1, r, rt << 1 | 1,val);
    return ANS;
}

int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&x[i]);
        Build(1,n,1);
        int last_cnt=0;
        for(int i=1;i<=n-1;i++)
        {
            last_cnt+=Query(i+1,n,1,n,1,x[i]);
        }
        int cnt=0;
        int ans=1e9;
        for(int i=1; i<n; i++)
        {
            cnt=last_cnt+n-1-2*x[i];
            last_cnt=cnt;
            ans=min(ans,cnt);
        }
        printf("%d\n",ans);
    }

    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值