解题报告 之 POJ1459 Power Network

解题报告 之 POJ1459 Power Network


Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p  max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c  max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l  max(u,v) of power delivered by u to v. Let Con=Σ  uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p  max(u)=y. The label x/y of consumer u shows that c(u)=x and c  max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l  max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l  max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p  max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c  max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

题目大意:有n个节点,包括有发电站,中转站和消费者。其中发电站有np个,消费者有nc个,剩余的为中转站。有m条输电线,分别给出m条输电线的起点终点和输电量,在分别给出发电站的最大发电量和消费者的最大消费量。问整个电网的最大消费量是多少?

分析:首先整个题目是一道阅读理解,不过还是没超过Johnson出题的阅读量。尽整些没用的。首先明确中转站是废的,完全可以不考虑。那么剩下的题抽象为一道最大流,而且比较裸,所以模板方面就沿用了某大神Dinic模板。居然一次敲过了哈哈。然后就是建图了。多源点汇点的问题引入超级源点、汇点。将每个电站与超级源点连一条边,容量为发电量。将每个消费者与超级汇点连一条边,容量为消费量。然后每条电线拉一条边,容量就是输电量。我是预留了0~100给中间的电线,然后用101做超级汇点,102做超级源点,因为有一些编号是没用的中转站,所以不好区分直接就预留出来比较方便。

另外一个要注意的是输入比较奇葩。建议用scanf,注意中间把空格读掉。

上代码:
#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#include<cstdio>
using namespace std;

const int MAXN = 300;
const int MAXM = 90000;
const int INF = 0x3f3f3f3f;
struct Edge
{
	int to, next, cap;
};

Edge edge[MAXM];
int head[MAXN], level[MAXN];
int src, des,cnt;

void addedge(int from,int to,int cap)
{
	edge[cnt].to = to;
	edge[cnt].cap = cap;
	edge[cnt].next = head[from];
	head[from] = cnt++;

	edge[cnt].to = from;
	edge[cnt].cap = 0;
	edge[cnt].next = head[to];
	head[to] = cnt++;
}

int bfs()
{
	queue<int> q;
	while (!q.empty())
		q.pop();
	memset(level, -1, sizeof level);
	level[src] = 0;
	q.push(src);

	while (!q.empty())
	{
		int u = q.front();
		q.pop();

		for (int i = head[u]; i != -1; i = edge[i].next)
		{
			int v = edge[i].to;
			if (edge[i].cap&&level[v] == -1)
			{
				level[v] = level[u] + 1;
				q.push(v);
			}
		}
	}
	return level[des] != -1;
}

int dfs(int u,int f)
{
	if (u == des) return f;
	int tem;
	for (int i = head[u]; i != -1; i = edge[i].next)
	{
		int v = edge[i].to;
		if (edge[i].cap > 0 && level[v] == level[u] + 1)
		{
			tem = dfs(v, min(f, edge[i].cap));
			if (tem > 0)
			{
				edge[i].cap -= tem;
				edge[i ^ 1].cap += tem;
				return tem;
			}
		}
	}
	level[u] = -1;
	return 0;
}

int Dinic()
{
	int ans = 0, tem;
	
	while (bfs())
	{
		while (tem=dfs(src, INF))
		{
			ans += tem;
		}
	}
	return ans;
}

int main()
{

	int n, np, nc, m;
	char ch;
	src = 102;
	des = 101;
	while (scanf("%d%d%d%d",&n,&np,&nc,&m)==4)
	{
		cnt = 0;
		memset(head, -1, sizeof head);
		int a, b, c;
		for (int i = 0; i < m; i++)
		{
			ch = getchar();
			while (ch != '(')
				ch = getchar();
			scanf("%d,%d)%d", &a, &b, &c);
			addedge(a, b, c); 
		}

		for (int i = 0; i < np; i++)
		{
			ch = getchar();
			while (ch != '(')
				ch = getchar();
			scanf("%d)%d", &a, &c);
			addedge(src, a, c);
		}

		for (int i = 0; i < nc; i++)
		{
			ch = getchar();
			while (ch != '(')
				ch = getchar();
			scanf("%d)%d", &a, &c);
			addedge(a, des, c);
		}

		::cout << Dinic() << endl;
	}
	return 0;
}

啦啦啦啦啦啦啦啦啦啦啦。虽然今天身份证找到了但是钱包还是掉的很凄惨。呵呵。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值