解题报告 之 POJ 2096 Collecting Bugs

6 篇文章 0 订阅

解题报告 之 POJ 2096 Collecting Bugs


Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It's important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan's opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan's work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan's working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

Source

Northeastern Europe 2004, Northern Subregion

题目大意:每天发现一个bug,这个bug发生在某一个模块,属于一个种类;且等可能发生在每个模块,等可能发生在每个种类。问要至少要发现发生在所有模块和所有种类的bugs所需要天数的期望。

分析:一道典型的概率dp,是二维棋盘可覆盖模型。我们把种类想成棋盘的行,把模块想成列,则问题转化为,每天随机指定一个格子,问至少要指到所有行和列所需要的天数期望。

我们用dp[i][j]表示已经覆盖 i 行,j 列(具体是哪些行列不重要)所需要的天数期望。那么明显dp[i][j]可以转化到四种状态。
下一次操作:
1.没有覆盖到新的行和新的列。 -->  i/n * j/s
2.覆盖到新行,不覆盖新列。    -->  (n-i)/n * j/s
3.不覆盖新行,但覆盖了新列。 -->  i/n * (s-j)/s
4.既覆盖了新行,也覆盖了新列。--> (n-i)/n * (s-j)/s
那么dp[i][j]就等于这四种状态所需要天数的加权期望+1天。

移项化简后转移方程为:
dp[i][j] = (1.0*(n - i)*j*dp[i + 1][j] + 1.0*i*(s - j)*dp[i][j + 1] + 1.0*(n - i)*(s - j)*dp[i + 1][j + 1] + n*s) / (double)(n*s - i*j);

注意这道题的特点是选过的点可以重复选,如果不能重复选则涉及到概率的动态变化,可以参考另一篇博文。

上代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

const int MAXN = 1e4 + 10;
double dp[MAXN][MAXN];

int main()
{
	int n, s;
	while(scanf( "%d%d", &n, &s ) == 2)
	{

		dp[n][s] = 0.0;
		for(int i = n; i >=0; i--)
		{
			for(int j = s; j >= 0; j--)
			{
				if(i == n&&j == s) continue; //注意这个格子不能更新,否则会出现错误
				dp[i][j] = (1.0*(n - i)*j*dp[i + 1][j] + 1.0*i*(s - j)*dp[i][j + 1] + 1.0*(n - i)*(s - j)*dp[i + 1][j + 1] + n*s) / (double)(n*s - i*j);
			}
		}
		printf( "%.4lf\n", dp[0][0] );
	}

	return 0;
}




  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值