hdu1841Find the Shortest Common Superstring

Find the Shortest Common Superstring

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2062    Accepted Submission(s): 570


Problem Description
The shortest common superstring of 2 strings S1 and S2 is a string S with the minimum number of characters which contains both S1 and S2 as a sequence of consecutive characters. For instance, the shortest common superstring of “alba” and “bacau” is “albacau”.
Given two strings composed of lowercase English characters, find the length of their shortest common superstring.
 

Input
The first line of input contains an integer number T, representing the number of test cases to follow. Each test case consists of 2 lines. The first of these lines contains the string S1 and the second line contains the string S2. Both of these strings contain at least 1 and at most 1.000.000 characters.
 

Output
For each of the T test cases, in the order given in the input, print one line containing the length of the shortest common superstring.
 

Sample Input
 
 
2 alba bacau resita mures
 

Sample Output
 
 
7 8
让一个串的前缀与令一个串的后缀匹配 其实与之前模式串与主串的匹配没有什么不同 还是模式串在一直后移 只是超过长度时返回已匹配的长度
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char a[1000005],b[1000005];
int n[1000005];
int len1,len2;
void kmp(char *t,int len)
{
    n[0]=-1;
    int k=-1;
    int j=0;
    while(j<=len)
    {
        if(k==-1||t[j]==t[k])
        {
            k++;
            j++;
            n[j]=k;
        }
        else k=n[k];
    }
}
int solve(char *c, char *d)
{
    int i=0,j=0;
    int tmp1=strlen(c),tmp2=strlen(d);


    kmp(d,tmp2);
    while(i<tmp1&&j<tmp2)    //j<tmp2 是d是c的主串那种情况
    {
        if(j==-1||c[i]==d[j])i++,j++;
        else j=n[j];
    }


    return j;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        scanf(" %s %s",a,b);
        len1=strlen(a);
        len2=strlen(b);
        int ans1=solve(a,b);
        int ans2=solve(b,a);
        cout<<(len1+len2-max(ans1,ans2))<<endl;


    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值