hdu 3336 Count the string

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10144    Accepted Submission(s): 4745


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
  
  
1 4 abab
 

Sample Output
  
  
6
dp[i]存的是第I个字符结尾的前缀数,DP【next[i]】是前一个字符的最大前后缀匹配长度 前缀已经算过了 所以这时候加上重复的后缀就是第i-1个字符的前缀数 再加上他自己 就是第i个字符结尾的前缀数
#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char a[200005];
int n[200005],dp[200005];
void kmp(int len)
{
    n[0]=-1;
    int k=-1;
    int j=0;
    while(j<=len)
    {
        if(k==-1||a[j]==a[k])
        {
            k++;
            j++;
            n[j]=k;
        }
        else k=n[k];
    }
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int len;
        memset(dp,0,sizeof(dp));
        cin>>len;
        for(int i=0;i<len;i++)
        scanf(" %c",&a[i]);
        kmp(len);
        int ans=0;
        for(int i=1;i<=len;i++)
        {
            dp[i]=dp[n[i]]+1;
            ans+=dp[i]%10007;
        }
        cout<<ans%10007<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值