japan

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.
Input
The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the East coast and second one is the number of the city of the West coast.
Output
For each test case write one line on the standard output:
Test case (case number): (number of crossings)
Sample Input
1
3 4 4
1 4
2 3
3 2
3 1
Sample Output
Test case 1: 5

记第i条边的端点分别为xi,yi。

由于x是从小到大排序的,假设当前我们在处理第k条边,那么第1~k-1条边的x必然是小于(等于时候暂且不讨论)第k条边的 x 的,那么前k-1条边中,与第k条边相交的边的y值必然大于yk的,所以此时我们只需要求出在前k-1条边中有多少条边的y值在区间[yk, M]即可,也就是求yk的逆序数,M为西岸城市个数,即y的最大值。 所以就将问题转化成区间求和的问题,树状数组解决。

当两条边的x相同时,我们记这两条边的y值分别为ya,yb(ya<yb),我们先处理(x,ya),再处理(x,yb),原因很明显,因为当x相同时,这两条边是认为没有交点的,若先处理(x,yb),那么下次处理(x,ya)时,(x,ya)就会给(x,yb)增加一个逆序,也就是将这两条边做相交处理了。

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1010;
struct city
{
    int s,e,val;
}a[maxn*maxn];
int c[maxn];
int lowbit(int i)
{
    return i&(-i);
}
int cmp(city a,city b)
{
    if(a.s!=b.s)return a.s<b.s;
    else return a.e<b.e;
}
int update(int i,int x)
{
    while(i<=maxn)
    {
        c[i]=c[i]+x;
        i=i+lowbit(i);
    }
}
int query(int i)
{
    int sum=0;
    while(i>0)
   {
        sum+=c[i];
        i=i-lowbit(i);
    }
    return sum;
}
int main()
{
    int t,n,m,k;
    while(scanf("%d",&t)!=-1)
    {
        for(int j=1;j<=t;j++)
        {
            memset(c,0,sizeof(c));
            scanf("%d%d%d",&n,&m,&k);
            for(int i=1;i<=k;i++)
            {
                scanf("%d%d",&a[i].s,&a[i].e);
            }
            sort(a+1,a+k+1,cmp);
            long long  sum=0;
            for(int i=1;i<=k;i++)
            {
                update(a[i].e,1);
                sum+=(i-query(a[i].e));

            }

        printf("Test case %d: %lld\n",j,sum);
        }
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值