The k-th Largest Group POJ - 2985 treap+并查集

Newman likes playing with cats. He possesses lots of cats in his home. Because the number of cats is really huge, Newman wants to group some of the cats. To do that, he first offers a number to each of the cat (1, 2, 3, …, n). Then he occasionally combines the group cat i is in and the group cat j is in, thus creating a new group. On top of that, Newman wants to know the size of the k-th biggest group at any time. So, being a friend of Newman, can you help him?
Input

1st line: Two numbers N and M (1 ≤ NM ≤ 200,000), namely the number of cats and the number of operations.

2nd to (m + 1)-th line: In each line, there is number C specifying the kind of operation Newman wants to do. If C = 0, then there are two numbers i and j (1 ≤ ij ≤ n) following indicating Newman wants to combine the group containing the two cats (in case these two cats are in the same group, just do nothing); If C = 1, then there is only one number k (1 ≤ k ≤ the current number of groups) following indicating Newman wants to know the size of the k-th largest group.

Output

For every operation “1” in the input, output one number per line, specifying the size of the kth largest group.

Sample Input
10 10
0 1 2
1 4
0 3 4
1 2
0 5 6
1 1
0 7 8
1 1
0 9 10
1 1
Sample Output
1
2
2
2
2
Hint

When there are three numbers 2 and 2 and 1, the 2nd largest number is 2 and the 3rd largest number is 1.


如果把两组合并 就把他们原来的节点从树上删掉 把合并后的节点加入即可 不用担心编号的改变 

因为都可以通过并查集查询到他们的那个最高级别的头 。

需要用一个变量记录当前节点数 因为合并后组数会变少 查询的时后有可能查询不到。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=200005;
int n;
int pre[maxn];
int num[maxn];
int find(int x)
{
    if(x!=pre[x])pre[x]=find(pre[x]);
    return pre[x];
}
struct node
{
    int l,r,val,size,w;
    int rnd;
}tree[maxn];
int size,root,cc;
int ans[50005];
struct node1
{
    int s,e,id,k;
}p[50005];
void update(int k)
{
    tree[k].size=tree[tree[k].l].size+tree[tree[k].r]
    .size+tree[k].w;
}
void lturn(int &k)
{
    int tmp=tree[k].r;
    tree[k].r=tree[tmp].l;
    tree[tmp].l=k;
    tree[tmp].size=tree[k].size;
    update(k);
    k=tmp;
}
void rturn(int &k)
{
    int tmp=tree[k].l;
    tree[k].l=tree[tmp].r;
    tree[tmp].r=k;
    tree[tmp].size=tree[k].size;
    update(k);
    k=tmp;
}
void insert(int &k,int x)
{
    //cout<<"insert "<<k<<endl;
    if(k==0)
    {
        size++;  //记录已经使用的结构体数目
        k=size;
        tree[k].val=x;
        tree[k].size=1;
        tree[k].w=1;
        tree[k].rnd=rand();
        return ;
    }
    tree[k].size++;
    if(tree[k].val==x)tree[k].w++;
    else if(x>tree[k].val)
    {
        insert(tree[k].r,x);
        if(tree[tree[k].r].rnd<tree[k].rnd)    //右子树优先级小于根子树
            lturn(k);
    }
    else
    {
        insert(tree[k].l,x);
        if(tree[tree[k].l].rnd<tree[k].rnd)
            rturn(k);
    }
}


void del(int &k,int x)
{
    if(k==0)return ;
    //cout<<"del"<<endl;
    if(tree[k].val==x)
    {
        if(tree[k].w>1)
        {
            tree[k].w--;
            tree[k].size--;
            return ;
        }


    if(tree[k].l*tree[k].r==0)k=tree[k].l+tree[k].r;   //如果没有左右子树或只有一个
    else if(tree[tree[k].l].rnd<tree[tree[k].r].rnd)
        rturn(k),del(k,x);
    else lturn(k),del(k,x);
    }
    else if(tree[k].val<x)tree[k].size--,del(tree[k].r,x);
    else tree[k].size--,del(tree[k].l,x);
}
void join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
    {
        
        if(num[fx]!=1&&num[fx]!=0)del(root,num[fx]),cc--;
        if(num[fy]!=1&&num[fy]!=0)del(root,num[fy]),cc--;
        pre[fy]=fx;
        num[fx]+=num[fy];
        
        insert(root,num[fx]);
        num[fy]=0;
        cc++;
        
    }
}
int query_num(int k,int x)
{
    if(k==0)return 0;
    //cout<<"rank "<<k<<endl;
    if(x<=tree[tree[k].r].size)
      {
        return query_num(tree[k].r,x);
      }
    else if(x>tree[tree[k].r].size+tree[k].w)
       {


        return query_num(tree[k].l,x-tree[tree[k].r].size
        -tree[k].w);
       }
    else
    {
        return tree[k].val;
    }
}
int main()
{
    int m;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        size=0,root=0;
        cc=0;
        memset(tree,0,sizeof(tree));
        //memset(num,1,sizeof(num));
        for(int i=1;i<=n;i++)
        pre[i]=i,num[i]=1;
        insert(root,1);
        while(m--)
        {
            int op;
            scanf("%d",&op);
            if(op==0)
            {
                int a,b;
                scanf("%d%d",&a,&b);
                join(a,b);
            }
            if(op==1)
            {
                int k;
                scanf("%d",&k);
                int ans=0;
               
                if(cc>=k)ans=query_num(root,k);
                else ans=1;
                printf("%d\n",ans);
            }
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值