二分入门

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Source

题意:给四组数,从每组中选一个数,使得四数之和等于零,问共有几种选法。
思路:先算出两次两组数的和,再用 二分法查找满足条件的数
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>

using namespace std;

const int maxn = 4005;
int a[maxn], b[maxn], c[maxn], d[maxn], sum_1[maxn * maxn], sum_2[maxn * maxn];
int n;

int main()
{
	scanf("%d", &n);
	for(int i = 0; i < n; i++)
	{
		scanf("%d%d%d%d", &a[i], &b[i], &c[i], &d[i]);
	}
	int k = 0, mid, ans;
	for(int i = 0; i < n; i++)
	{
		for(int j = 0; j < n; j++)
		{
			sum_1[k] = a[i] + b[j];
			sum_2[k++] = c[i] + d[j];
		}
	}
	sort(sum_2, sum_2 + k);
	ans = 0;
	for(int i = 0; i < k; i++)
	{
		int l = 0, r = k - 1;
		while(l <= r)
		{
			 mid=(l + r) / 2;
			if(sum_1[i] + sum_2[mid] == 0)
			{
				ans++;
				for(int j = mid + 1; j < k; j++)//判断该数右边有没有与之相等的数
				{
					if(sum_1[i]+sum_2[j]!=0)
						break;
					else
					ans++;
				}
				for(int j = mid - 1; j >= 0; j--)//判断该数右边有没有与之相等的数

				{
					if(sum_1[i]+sum_2[j]!=0)
						break;
						else
						ans++;
				}
				break;
			}
			if(sum_1[i]+sum_2[mid]<0)
				l = mid + 1;
			else
				r = mid - 1;
		}
	}
	printf("%d\n", ans);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值