Fibbonacci数列——杭电POJ2070

这到题,开始用递归,可是时间超出,于是在主函数中循环解决问题。

Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.
 

Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
 

Output
Print out the answer in a single line for each test case.
 

Sample Input
  
  
3 4 5 -1
 

Sample Output
  
  
2 3 5
Hint
Note:
you can use 64bit integer: __int64
import java.util.Scanner;


public class POJ2072 {
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		
		while(cin.hasNext()) {
			int a = cin.nextInt();
			
			if (a == -1)
				break;
			
//			System.out.println(Fibbonacci(a));
			long f = 0;
			long f1 = 0;
			long f2 = 1;
			if (a == 0)
				f = f1;
			if (a == 1)
				f = f2;
			if (a > 1) {
				for (int i = 1; i < a ; i ++) {
					f = f1 + f2;
					f1 = f2;
					f2 = f;
				}
			}
			System.out.println(f);
		}
	}
	
	public static int Fibbonacci(int n) {
		if (n == 0)
			return 0;
		else if (n == 1)
			return 1;
		else if (n != 0 && n != 1)
			return Fibbonacci(n - 1) + Fibbonacci(n - 2);
		return 0;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值