蓝桥杯 算法提高VIP 递归倒置字符数组(Java解题)

112 篇文章 7 订阅

【题目链接】:递归倒置字符数组

【题目描述】:

完成一个递归程序,倒置字符数组。并打印实现过程 
递归逻辑为: 
当字符长度等于1时,直接返回 
否则,调换首尾两个字符,在递归地倒置字符数组的剩下部分 
输入
字符数组长度及该数组 
输出
在求解过程中,打印字符数组的变化情况。 
最后空一行,在程序结尾处打印倒置后该数组的各个元素。 
样例输入
5 abcde
样例输出
ebcda
edcba

edcba
【代码】:
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int a = sc.nextInt();
		String s = sc.next();
		char c[] = s.toCharArray();
		for (int i = 0; i < c.length / 2; i++) {
			/**交换位置*/
			char t = c[i];
			c[i] = c[c.length - 1 - i];
			c[c.length - 1 - i] = t;
			/**输出交换后序列*/
			for (int j = 0; j < c.length; j++)
				System.out.print(c[j]);
			System.out.println();
		}
		System.out.println();
		for (int j = 0; j < c.length; j++)
			System.out.print(c[j]);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值