杭电1007 Quoit Design

题目内容:

Problem Description
Have you ever played quoit in a playground? Quoit is a game in which flat rings are pitched at some toys, with all the toys encircled awarded.
In the field of Cyberground, the position of each toy is fixed, and the ring is carefully designed so it can only encircle one toy at a time. On the other hand, to make the game look more attractive, the ring is designed to have the largest radius. Given a configuration of the field, you are supposed to find the radius of such a ring.

Assume that all the toys are points on a plane. A point is encircled by the ring if the distance between the point and the center of the ring is strictly less than the radius of the ring. If two toys are placed at the same point, the radius of the ring is considered to be 0.
 

Input
The input consists of several test cases. For each case, the first line contains an integer N (2 <= N <= 100,000), the total number of toys in the field. Then N lines follow, each contains a pair of (x, y) which are the coordinates of a toy. The input is terminated by N = 0.
 

Output
For each test case, print in one line the radius of the ring required by the Cyberground manager, accurate up to 2 decimal places. 
 

Sample Input
  
  
2 0 0 1 1 2 1 1 1 1 3 -1.5 0 0 0 0 1.5 0
 

Sample Output
  
  
0.71 0.00 0.75


题目大意:

对于给定的点,找到距离最近的两个点的距离,并且把它的一半作为输出结果,即题目所说的环的最小半径


题目分析:

这道题的关键是在于数学方面,可以证得最近的两个点一定是横坐标上的相邻点或者纵坐标上的最近点,然后再代入相应的另一个数据,进行求算即可,注意对于时间复杂度的优化


题目代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>

using namespace std;

typedef struct
{
    double xi;
    double yi;
}data;

int n;
data xsort[100005];
data ysort[100005];

int cmpx(data a,data b)
{
    if(a.xi<b.xi)
        return 1;
    else if(a.xi>b.xi)
        return 0;
    else
    {
        if(a.yi<b.yi)
            return 1;
        else
            return 0;
    }
}

int cmpy(data a,data b)
{
    if(a.yi<b.yi)
        return 1;
    else if(a.yi>b.yi)
        return 0;
    else
    {
        if(a.xi<b.xi)
            return 1;
        else
            return 0;
    }
}

double mins(double a,double b)
{
    return a<b?a:b;
}

double dd(double a)
{
    return a*a;
}

int main()
{
    while(scanf("%d",&n),n!=0)
    {
        memset(xsort,0,sizeof(xsort));
        memset(ysort,0,sizeof(ysort));
        double min=999999;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&xsort[i].xi,&xsort[i].yi);
            ysort[i].xi=xsort[i].xi,ysort[i].yi=xsort[i].yi;
        }
        sort(xsort,xsort+n,cmpx);
        sort(ysort,ysort+n,cmpy);
        min=dd(xsort[0].xi-xsort[1].xi)+dd(xsort[0].yi-xsort[1].yi);
        for(int i=1;i<n-1;i++)
        {
            min=mins(min,dd(xsort[i].xi-xsort[i-1].xi)+dd(xsort[i].yi-xsort[i-1].yi));
            min=mins(min,dd(xsort[i].xi-xsort[i+1].xi)+dd(xsort[i].yi-xsort[i+1].yi));
        }
        min=mins(min,dd(xsort[n-1].xi-xsort[n-2].xi)+dd(xsort[n-1].yi-xsort[n-2].yi));
        min=mins(min,dd(ysort[0].xi-ysort[1].xi)+dd(ysort[0].yi-ysort[1].yi));
        for(int i=1;i<n-1;i++)
        {
            min=mins(min,dd(ysort[i].xi-ysort[i-1].xi)+dd(ysort[i].yi-ysort[i-1].yi));
            min=mins(min,dd(ysort[i].xi-ysort[i+1].xi)+dd(ysort[i].yi-ysort[i+1].yi));
        }
        min=mins(min,dd(ysort[n-1].xi-ysort[n-2].xi)+dd(ysort[n-1].yi-ysort[n-2].yi));
        printf("%.2lf\n",(double)sqrt(min)/2);
    }
    return 0;
}

解题评价:


看到discuss区很多人都说这是一个分治法的经典题目,其实我在题目中也运用了分治的思想,不过我仍然认为这道题的最主要是在于数学思想和时间优化


当前水平评分:4

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值