python 中while true练习1

这段代码演示了一个无限循环,不断接收用户输入并将其添加到items列表中,直到用户输入0时结束循环,并打印出items列表。示例输入为1、2、3和0,输出结果为[1, 2, 3]。这是一个基本的Python交互式编程示例,涉及条件判断、列表操作和用户输入处理。
摘要由CSDN通过智能技术生成

The given code uses an infinite loop to continuously take user input.
During each iteration, the user input is added to the items list.

Change the code to end the loop when the user enters 0.
Output the resulted list after the while loop ends.

Sample Input
1
2
3
0

Sample Output
[1, 2, 3]

#my code
items = []

while True:

    n = int(input())
    if n==0:
    	print(items)
    	break
    	
    	
    else:
    	items.append(n)

    	continue
    ```
    
    	
    	
    
    	

    

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

melanie萱

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值