【A - Til the Cows Come Home 】最短路径

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

  • Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
    Output
  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
    Sample Input
    5 5
    1 2 20
    2 3 30
    3 4 20
    4 5 20
    1 5 100
    Sample Output
    90
```
/*
    n个点,m条边,求1 - n 的距离

    输入x y z,表示x到y的距离为z 

    不存在输出-1 
    Dijkstra算法:
    1.初始化,把dis数组(表示点到起点的距离)更新为无穷大
    。根据输入建立双向边。
    2.首先把起点入优先队列,依次从优先队列中取首元素,标记该点。更新从该点出发,可以到达的所有点的距离
    。循环到结束
    3.判断起点到终点的距离是否为无穷大。 

*/
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
struct Pair
{
    int first,second;       //first存点,second存距离 
    bool friend operator < (Pair a,Pair b)
    {
        return a.second > b.second;
    }
}pr,ne;
int n,m;
vector<int> edge[1010];     //存与之相连的边 
int length[1010][1010];     //存相连边的长度 
int dis[1010];      //记录到起点的距离 

void dijkstra()
{
    memset(dis,INF,sizeof(dis));
    /* 
    第二个参数可以填 0,-1,1,其他 
    0:把元素都初始化为0
    -1:初始化为-1
    1:初始化为一个奇怪的值
    其他:其他 
    */ 
    bool vis[105];
    memset(vis,false,sizeof(vis));
    dis[1] = 0;
    pr.first = 1;
    pr.second = 0;
    priority_queue<Pair> Q;
    Q.push(pr);
    while (!Q.empty())
    {
        pr = Q.top();
//      printf ("==%d %d==\n",pr.first,pr.second);
        Q.pop();

        if (vis[pr.first])
            continue;
        vis[pr.first] = true;
        for (int i = 0 ; i < edge[pr.first].size() ; i++)
        {
            ne.first = edge[pr.first][i];
            ne.second = pr.second + length[pr.first][ne.first];

            if (ne.second < dis[ne.first])
            {
                dis[ne.first] = ne.second;
                Q.push(ne);
            }
        }
    }
}

int main()
{
    scanf ("%d%d",&m,&n);
    memset(length,-1,sizeof(length));
    for (int i = 1 ; i <= m ; i++)
    {
        int x,y,z;
        scanf ("%d%d%d",&x,&y,&z);
        edge[x].push_back(y);
        edge[y].push_back(x);       //双向存图 

        if (length[x][y] == -1)//无向图两个点之间可能有两条边,去较小的那一条; 
            length[x][y] = length[y][x] = z;
        else
            length[x][y] = length[y][x] = min(z,length[x][y]);
    }
    dijkstra();
    printf ("%d\n",dis[n]);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值