HDOJ1002 A + B Problem II

 A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 212359    Accepted Submission(s): 40969


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 


Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 


Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 


Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 


Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
//大数相加可转换为字符串
代码:
第一种: 
#include<stdio.h>
#include<string.h>
int main()
{
    int t,n,m;
    int la,lb,p;
    int i,j;
    char a[1000],b[1000],c[1001];
    scanf("%d",&t);
    for(j=1;j<=t;j++)
    {
        scanf("%s%s",a,b);
        printf("Case %d:\n",j);
        printf("%s + %s = ",a,b);
        la=strlen(a)-1;
        lb=strlen(b)-1;
        p=0;
        for(i=0;la>=0||lb>=0;i++,la--,lb--)
        {
            if(la>=0&&lb>=0)
               c[i]=a[la]+b[lb]-'0'+p;
            if(la>=0&&lb<0)
               c[i]=a[la]+p;
            if(lb>=0&&la<0)
               c[i]=b[lb]+p;
            p=0;
            if(c[i]>'9')
            {
               c[i]=c[i]-10;
               p=1;
            }
        }
        if(p==1)
           printf("1");
        while(i--)
           printf("%c",c[i]);
        if(j<t)
           printf("\n\n");
        else
           printf("\n");
    }
    return 0;
}
第二种:
#include <stdio.h>
#include <string.h>
#define MAX 1010
int an1[MAX];
int an2[MAX];
char s1[MAX];
char s2[MAX];
int t,i,j,k;
int main(void)
{
 scanf("%d",&t);
 for(i=1;i<=t;i++)
 {
    scanf("%s", s1);
    scanf("%s", s2);
    memset( an1, 0, sizeof(an1));
    memset( an2, 0, sizeof(an2)); 
    int nLen1 = strlen( s1);
    for( j = 0, k = nLen1 - 1;k >= 0 ; k --)
        an1[j++] = s1[k] - '0';
    int nLen2 = strlen(s2);
    for( j = 0, k = nLen2 - 1;k>= 0 ; k --)
        an2[j++] = s2[k] - '0';
    for(k = 0;k < MAX ; k ++ ) 
    {  an1[k] += an2[k]; //逐位相加
        if( an1[k] >= 10 ) 
        { //看是否要进位
            an1[k] -= 10;
            an1[k+1] ++; //进位
        }
    }
    for( k = MAX; (k >= 0) && (an1[k] == 0);k -- ) ;
    printf("Case %d:\n", i);
    printf("%s + %s = ",s1,s2); 
    if(k>=0)
        for( ; k >= 0; k--)
            printf("%d",an1[k]);
    if(i==t) printf("\n");
    else printf("\n\n");
 }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值