c++大数加减法的实现

输入

第一行,输入一个正整数 T (1<=T<=30)

然后有T行,每行两个整数 a 和 b


输出

对于每对 a和b,输出 a+b 的结果

样例输入

4
1 2
-5 3
1 -1
-1111111111111 2222222222222

样例输出

3
-2
0
1111111111111

题目来源



源代码:

#include<iostream> 
#include<string> 
using namespace std;
int str2num(string str,int *a)
{
	int len,len1,i;
	if(str[0]!='-')
{
	len=str.length(); 
	len1=0;
	for(i=len-1;i>=0;i--) 
	{
	a[len1++]=str[i]-'0';
	}
} 
else
{
	len=str.length(); 
	len1=0;
	for(i=len-1;i>=1;i--) 
	{
	a[len1++]=str[i]-'0';
	}
}
	return len1;
}
void subtract(int *a,int *b,int len,string str1)
{
	int index;
	int i;
	for(i=0;i<len-1;i++)
			if(a[i]>=b[i])
				a[i]-=b[i];
			else
			{
				a[i]=a[i]+10-b[i];
				a[i+1]-=1;
			}
			a[len-1]-=b[len-1];
			
			index=len-1;//
			while(a[index]==0&&len>0)index--;//
			if(str1[0]=='-')
				cout<<'-';
			for(i=index;i>=0;i--) 
				cout<<a[i]; 
				cout<<endl; 
}
int main() 
{ 
string str1,str2; 
int a[10000],b[10000],len,len1,len2; 
int i,index;  

int T;
cin>>T;
while(T--)
{
memset(a,0,sizeof(a)); 
memset(b,0,sizeof(b)); 
cin>>str1>>str2; 
len1=str2num(str1,a);
len2=str2num(str2,b);
if(str1[0]!='-'&&str2[0]!='-'||str1[0]=='-'&&str2[0]=='-')
{
	len=(len1>len2?len1:len2); 
	for(i=0;i<len;i++) 
	{ 
		a[i]+=b[i]; 
		a[i+1]+=a[i]/10; 
		a[i]%=10; 
	} 
	index=len;//
	while(a[index]==0&&len>0)index--;//

	if(str1[0]=='-'&&str2[0]=='-')
		cout<<'-';
	
	for(i=index;i>=0;i--) 
	cout<<a[i]; 
	cout<<endl; 
}
else if(str1[0]!='-'&&str2[0]=='-'||str1[0]=='-'&&str2[0]!='-')
{
	len=(len1>len2?len1:len2); 
	int flag=3;
	for(i=len-1;i>=0;i--)
	{
		if(a[i]>b[i])
		{
		flag=1;
		break;
		}
		else if(a[i]<b[i]) 
		{
		flag=2;
		break;
		}	
	}
	switch(flag)
	{
	case 1:
		subtract(a,b,len,str1);
		break;
	case 2:
		subtract(b,a,len,str2);
		break;
	case 3:
		cout<<0<<endl;
		break;
	}
	
}
}
return 0; 
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
以下是一个简单的 C++ 大数实现,它可以实现大数的加减运算: ``` #include <iostream> #include <string> #include <algorithm> using namespace std; class BigInt { public: string num; BigInt() {} BigInt(string s) { num = s; } BigInt operator+(BigInt b) { BigInt res; int carry = 0; int len1 = num.length(), len2 = b.num.length(); int len = max(len1, len2); for (int i = 0; i < len; i++) { int a = i < len1 ? num[len1 - 1 - i] - '0' : 0; int b = i < len2 ? b.num[len2 - 1 - i] - '0' : 0; int sum = a + b + carry; carry = sum / 10; sum = sum % 10; res.num.insert(0, to_string(sum)); } if (carry) { res.num.insert(0, to_string(carry)); } return res; } BigInt operator-(BigInt b) { BigInt res; int borrow = 0; int len1 = num.length(), len2 = b.num.length(); int len = max(len1, len2); for (int i = 0; i < len; i++) { int a = i < len1 ? num[len1 - 1 - i] - '0' : 0; int b = i < len2 ? b.num[len2 - 1 - i] - '0' : 0; int diff = a - b - borrow; if (diff < 0) { diff += 10; borrow = 1; } else { borrow = 0; } res.num.insert(0, to_string(diff)); } while (res.num.length() > 1 && res.num[0] == '0') { res.num.erase(0, 1); } return res; } void print() { cout << num << endl; } }; int main() { BigInt a("123456789"), b("987654321"); BigInt c = a + b; BigInt d = b - a; c.print(); // 输出 1111111110 d.print(); // 输出 864197532 return 0; } ``` 以上代码实现了 BigInt 类,这个类包含了 num 字符串,用来存储大数。它的构造函数可以接受一个字符串作为参数,用于初始化大数。 类中的 `operator+` 和 `operator-` 分别实现大数的加法和减法。其中,加法的实现比较简单,使用了竖式加法的思想,从低位开始逐位相加,最后将结果逆序输出即可。减法实现稍微复杂一些,需要考虑借位的情况。 最后,我们在 `main` 函数中创建了两个大数 a 和 b,分别进行了加法和减法运算,并将结果打印出来。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值