记录paddlepaddle配置环境踩的坑

记录paddlepaddle配置环境踩的坑

踩坑背景

一直在用的老台式机,CPU AMD X3-710开四核,显卡GTS450-512M,8G内存,硬盘两块固态一块机械。还想着发挥余热,并且本就装的Ubuntu+win10双系统,这就是踩坑的开始…

从Ubuntu开始

刚接触paddle从听课开始,然后准备配置自己的环境试试本地跑代码。

  1. 没经验直接装了高版本,paddle2.0.0-GPU CUDA10.2,后来发现GTS450显卡驱动最高支持CUDA9.1;
  2. 安装CUDA9.1,
  3. 卸载重装paddle2.0.0-GPU CUDA9.0,也不能用,发现还需要cudnn;
  4. 注册NVIDIA账号下载CUDNN对应CUDA9.1的版本也报错。
  5. 重新安装CUDA9.0+CUDNN7.6.5,报错。
  6. 安装了好几个版本paddle,报错找不到GPU
  7. 中间发现好多项目都还没升级paddle2.0,又换paddle1.8.5,还是报错

小白看不懂错误提示,只知道嗯不行,嗯还是不行。

转战win10

Ubuntu折腾了两天,发现百度好多答案都使用的windows,于是转战win10

  1. 安装anaconda、git、VS2017,再装paddle1.8.5-GPU,这才发现原来安装包有对应CUDA和CUDNN的编号。
  2. 按照python3.8、CUDA9.0、cudnn7.6.5的环境下载paddle-gpu
    1.8.5.post97 CP38版本,发现提示AVX错误。嗯经过几天蹂躏大概可以看出来是哪有问题了。
  3. 查阅文档发现是CPU不支持AVX,于是下载了paddle-gpu1.8.5.post97 CP38 的noavx版本,提示cudnn错误。
  4. 换了好几个noavx版本要么找不到gpu,要么AVX错误。
  5. 这时看到还有自己编译的方法,干脆动手自己编译。下载CMAKE安装文件,安装发现测试不通过,再下载二进制文件,手动配置环境变量还是不通过。鼓捣半天,关掉当前shell,再打开可以了…
  6. 然后研究说明文档,CMAKE1.8版本GPU noavx cp38的paddle
    cmake .. -G "Visual Studio 15 2017 Win64" -DCMAKE_BUILD_TYPE=Release -DWITH_GPU=ON -DWITH_TESTING=OFF -DPY_VERSION=3 -WITH_AVX=OFF
  7. VS打开paddle.sln,生成 ,看着那一排排错误我陷入了沉思…

吃饱撑的,为什么不用aistudio非得自己配环境呢。。。

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 深蓝海洋 设计师:CSDN官方博客 返回首页