Oracle解决向后兼容

解决向后兼容  
问题的一般步骤如下:  
     
   导出数据库的版本比目标数据库老的情况:  
   - 在需要导入的目标数据库中执行旧的CATEXP.SQL  
   - 使用旧的EXPORT导出DUMP文件   
   - 使用旧的IMPORT导入到数据库中  
   - 在数据库中执行新的CATEXP.SQL,以恢复该版本的EXPORT VIEW  
 
   导出数据库的版本比目标数据库新的情况:  
   - 在需要导入的目标数据库中执行新的CATEXP.SQL  
   - 使用新的EXPORT导出DUMP文件   
   - 使用新的IMPORT导入到数据库中  
   - 在数据库中执行旧的CATEXP.SQL,以恢复该版本的EXPORT VIEW  

换据话说:

导出数据库为816 目标为817
在817上执行816的catexp.sql
使用816的exp导出dmp文件
使用816的imp导入817中
在816中执行817的catexp.sql,以恢复该版本的export view

导出数据库为817 目标为9
在9上执行817的catexp.sql
使用817的exp导出dmp文件
使用817的imp导入9中
在817中执行9的catexp.exe,以恢复该版本的export view

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页