hdu 5233 Gunner II【STL应用】【水题】

Gunner II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1607    Accepted Submission(s): 604


Problem Description
Long long ago, there was a gunner whose name is Jack. He likes to go hunting very much. One day he go to the grove. There are n birds and n trees. The i-th bird stands on the top of the i-th tree. The trees stand in straight line from left to the right. Every tree has its height. Jack stands on the left side of the left most tree. When Jack shots a bullet in height H to the right, the nearest bird which stands in the tree with height H will falls.

Jack will shot many times, he wants to know which bird will fall during each shot.
 


Input
There are multiple test cases (about 5), every case gives n, m in the first line, n indicates there are n trees and n birds, m means Jack will shot m times.

In the second line, there are n numbers h[1],h[2],h[3],…,h[n] which describes the height of the trees.

In the third line, there are m numbers q[1],q[2],q[3],…,q[m] which describes the height of the Jack’s shots.

Please process to the end of file.

[Technical Specification]

All input items are integers.

1<=n,m<=100000(10^5)

1<=h[i],q[i]<=1000000000(10^9)
 


Output
For each q[i], output an integer in a single line indicates the id of bird Jack shots down. If Jack can’t shot any bird, just output -1.

The id starts from 1.
 


Sample Input
  
  
5 5 1 2 3 4 1 1 3 1 4 2
 


Sample Output
  
  
1 3 5 4 2
Hint
Huge input, fast IO is recommended.


二位数组是永远开不了那么大的,看到数据就应该知道这一点,所以要应用map,但是这里是一个一个干掉这个高度的鸟的,所以这里应用map+queue的组合就能AC了~
但是不知道为什么交G++是MLE,但是交C++就能AC~

#include<stdio.h>
#include<string.h>
#include<map>
#include<queue>
using namespace std;
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        map<int,queue<int> >map;
        for(int i=1;i<=n;i++)
        {
            int k;
            scanf("%d",&k);
            map[k].push(i);
        }
        for(int i=1;i<=m;i++)
        {
            int k;
            scanf("%d",&k);
            if(map[k].size()==0)
            {
                printf("-1\n");
            }
            else
            {
                printf("%d\n",map[k].front());
                map[k].pop();
            }
        }
    }
}








  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值